Ring Security - Extend Heimdall with Ring Security products

I might be a bit lost here, but you are saying the Keypad can still be used to activate alarm and modes even when not connected to the Ring app? So basically connect it to Homey, and it will still work with the Ring alarm system (just not be shown as an added device in the official Ring app)? I have read about people using Homey with the Ring Keypad v2 to be able to set alarm modes, so I know there is a solution here, Im just not seeing it right now :sweat_smile:

Now you lost me :wink: I just said a z-wave device can only be connected to one controller, I never said you’d be able to use it with a controller it’s not connected to.

You’ve read people use the Ring Keypad with Homey and use it to ‘set alarm modes’, are you sure they are talking about the Ring Alarm system or are they refering to setting the Heimdall Surveillance Mode?

Aha, I was under the impression that the combination of Heimdall and Ring Security would allow me to turn my Ring alarm system on and off with Homey, so for instance I could have a flow that turned off the alarm system when my front door smart lock was unlocked.

But after reading things a bit better, I see that the point of your app is to actually use components from the Ring alarm system as its own alarm system using Heimdall (am I getting this right now?).

I guess there is no way (at the moment at least) to get the functionality I am hoping for?

Correct. You cannot link ring security with homey. This app uses the components in heimdall.

I’m a big fan of heimdal and when i was looking for a keypad I came across this thread (and app).

I ordered a ring keypad v2 several months back but it has been out of stock everywhere so i just got it a few days a go. I’ve read the whole thread and tried almost everything but I can not get it to work properly.

It is as if the keypad freezes, it is responding when I touch the buttons but it cant send/receive information regarding armed/disarmed. If I try to send frames/test it under z-wave network on the developer site for homey it works.

I’ve tried rebooting homey, uninstall and install the ring security app. Tried inactivate Heimdall app (not uninstall), rebooting Heimdall and ring security app but I cant find anything that I would suspect could be a “root cause” of the problem. I’ve tried excluding and including the device several times and also factory resetting it.

There’s no problem including the device and most of the times when I’ve included the keypad it works fine for a few arming, disarming events but then it just stops. If I leave it and come back a few hours later it then sometimes works for a few more arming, disarming events before it goes back to “freezing”/not responding/falling “out of synch” with the actual surveillance status of heimdal.

As mentioned I had to wait a few months to get a hold of the keypad v2 since no one had it in stock, could it be that my keypad is a new revision with a new firmware or has anyone else reported these kind of issues before? The modelnumber of my keypad v2 is 5B28S8 and in homey it says firmware version 2.0 (firmwareid 769).

@DaneedeKruyff could i perhaps send a diagnostics report of the ring security app for you too look at or do you perhaps already have an idea, from my description, what could be causing this behavior for the keypad?

Hi @Fredrik_Backman

Sure, you can send me a diagnostics report. To have all possible information available, please take the following steps (in this order): stop and start Heimdall, wait 30 seconds and stop and start Ring Security. Wait 30 seconds again and then send a diagnostics report from both apps, in this case the order doesn’t matter.
Now try to reproduce the problem you’re experiencing and send me a report from both apps again when it occurs.

If the problem is in either app or the communication between them I should be able to see it in the logs otherwise it’s most likely a problem in your Z-Wave network, I can’t really imagine it’s a faulty device that sometimes works and sometimes not.
But let’s see what your logs can tell me.

Thanks for the quick response!

I did as instructed, stop and started heimdal, waited and then stop and started ring security. Below is the references given when I created the reports.

Heimdal: e4ec5637-a93e-46d5-86c1-6eb3d26fbe4f
Ring security: 167ee9af-eadd-424f-b3c8-07beda3ce8eb

After I started and stopped the apps the keypad responded when i changed the surveilance mode in homey, I partialy armed it and disarmed it which it responded to but then it “froze” and I couldn’t arm/disarm with the keypad neither did it change the state when i change the surveilance mode in homey.

After it froze i created new diagnostics reports with the following references:

Heimdal: 0a324eea-a8a2-44c0-a625-dbb9ba41220e
Ring security: 383c7db9-7ab0-4c3d-bf37-a7ec26af666c

The keypad is located 2m from my homey and i’ve tried having it connected to power aswell as being battery operated. I cant see any thing wrong in the z-wave network when i check the developer tools for homey. The node respons both to the “test” and “send test frame” command.

Hopefully you find something in the reports, it would be awesome to get this to work, the keypad would realy make heimdal the complete security system.

Hi @Fredrik_Backman,

I’ve received the reports, I’ll look at them and report back.

So now we are just waiting for support for Motion Detector and Contact sensor v2 from Ring, @DaneedeKruyff :heart_eyes:

Hi @Fredrik_Backman,

I’ve checked the logs and all communication between the apps work well but it shows a timeout at the Z-Wave sendcommand.
This means no response is coming back to Homey after sending the Z-Wave instructions to the device. Unfortunately this is beyong the control of the Ring Security app, the app just tells Homey what information to send to the device and Homey takes care of the rest.

@KjetilK unfortunatly I don’t have these devices and seeing how many times the V1 contact and motion sensors are installed compared to keypads I’m not gonna buy the V2 devices.

That said, I’ve received the product ID’s for the devices so I’ve tried adding the contact sensor V2 to the app but waiting for it to be tested.
The documentation on these devices isn’t great so I have no idea if it will work, but if you like to give it a try, feel free to do so.
(Also, I have no pairing images and a decent device icon, that will follow later if I can get the devices actualy working)

The version can be found on github: GitHub - daneedk/com.ring.security
please post your findings here: Ring Door Contact not recognized · Issue #5 · daneedk/com.ring.security · GitHub

(Need to know how to install from the CLI? Check here: [HOW TO] CLI install method)

Thank you so much for investigating. I do have a big zwave network but with plenty of route devices in the mesh and since I don’t experience any problems with the other devices I can’t shake the feeling that there’s something with the keypad. It works on and off and I also realized that the battery indicator never lights up. It could perhaps be far fetched but I will return the device to the store and buy a new one (hopefully they accept the return purchase). I’ll post here then and let you know if there’s any change in the behavior of a new keypad.

That seemed a bit to complicated for me, but let me know when you have included it in a beta app or something, and I can test it for you :sweat_smile:

I have this exactly same issue as Fredrik with my Ring Keypads. It works for some minutes but then it freezes and I need to restart all apps. Then it works again for some minutes and freezes. I even have Zwave extender to have good coverage, but it wont help

That’s unfortunate, but it’s beyond my control. The actual Z-Wave communication is handled by Homey, not by an app. Apps just give Homey a command to send data and Homey should take care of the rest.
Are you running your keypad on battery or on mains power? While the Ring Keypad V2 support FLIRS it may miss out on a command send from Homey, running it on mains power may be an improvement.

I was using them with battery but now I tested resetting them and using mains power. Same thing still. I can do all changes in the settings and they update. For example the language or the pin sound. I am using 2 of them, do I need to do some changes to the groups? Both of them are in group “1”.

Created also some reports for you, Ring Security: d7d48dbc-3bbe-4c67-8263-ef405fb3de5a
Heimdall: 9afb-5692-9bf5-4ec4-b8a9-f4b914266653

Also on the delevoper tools in the zwave meny I can see that the keypads have TX queued and Tx sent and each time I put pincode in it gets more TX queued and sent but not errors, so that means I guess the Homey gets the commands from keypad? I am really starting to think that there is something wrong with this model, I have exactly same model as Fredrik also

Edit and some more info:
Sorry for many posts, but I am writing as I go along and find some problems, I usually get a error message if I try to change key tone volume or any advanced settings but after I restart Heimdall everything works in the settings menu. Then if I try to put a pin code in to the keypad and change a armed state it will hang again in the advanced menu. It feels like the keypad and the Ring Security is working but something with the integration with Heimdall that makes it hang, cause I think its sending the armed status through homey but doesn’t receive anything back and Heimdall doesn’t send anything back to the keypad.
Like I said it in Zwave developer Homey gets all Txses.

What is also interesting if you wait 5min without restarting Heimdall the advanced settings will start to work, but directly after you try to put pincode in it stops working.
Also one thing I found was that Homeykit plugin when added the keypads to Homekit, it gives an error message on the Home app in an iPhone that the keypad doesn’t respond. So somehow Homeykit can see it not responding. I tried removing them from there also but its not making anything different.

I also tried with only one keypad with it plugged in and its still the same issue as before

EDIT 3:
Now I have gotten 1 keypad to work all the time when u reset it with the pin on the back. It works for a couple of minutes, the second keypad will get the command but the second keypad cant change armed state. It will only show and say what the first keypad did. Nothing else.

EDIT4: I resetted my whole Zwave network, I can get one to work and the other one will announce the arming states, but the second one will not arm or disarm. Is it so that 2 keypads are not implemented?

EDIT 5: Tried removing the non working keypad and just have one hooked up to homey. It works for couple of minutes after that it doesn’t responded anymore. Same as before, doesn’t show any TX error, and shows that its working in the development panel when u test it there. When you reset with pin on the back to “wake it up” it works again for couple of minutes. Like Fredrik said. Cant at all understand these problem with this keypad.

Hi @Dennis93,

Thanks for your extensive testing and reports but I’m afraid I can’t be of much help when timeouts occur, that happens an a lower communication layer than an app has access to.
The Ring Security app can do nothing more then send a command to Homey, which is then send to a device by Homey. In this communication the timeout occurs. Normally when a successful communication takes place the result is relayed back by Homey to the Ring Security app and the app can take the desired action, but when the communication between Homey and a device isn’t completed within 30 seconds Homey will report a timeout back to the app and this is exactly what I can see in the logs.

So how to fix this? I have extenders and I also have zwave plugs still it the keypads doesnt use them, they still use directly to homey. Do you think enabling experimental updates on homey could fix this problem, currently I don’t have that active. So weird that the keypad just want to use direct zwave contact with the homey and not through extenders.