Ring image grabber problem

I’ve got a battery-powered Ring. Glad to test anything (or almost anything :stuck_out_tongue: ) you throw at me :slight_smile:

I would love the possibility to get an image grab when someone’s at the door! :slight_smile:


I own a Ring V2 with battery back up. If I can test anything let me know.

1 Like

I am also availeble to test with the battery Function.

1 Like

@denniedegroot I see there has been an update to the master branch 5 days ago. I just noticed i’ve got version 2.1.1 installed of the Ring.com app which is a beta. I haven’t installed this through CLI, so did it get removed from the apps site?

And is the version in the master branch with the batteryfix the latest version? Which seems to be 2.0.5? I’m not entirely sure anymore.

2.0.5 is the latest version. The 2.1.1 beta is indeed removed because the features don’t work anymore.

However if you have the 2.1.1 beta installed it will probably not upgrade to 2.0.5 because its a lower version.

Right, so the advise is to remove and install 2.0.5?

Could you have a look at Aanmelden Ring PRO Homey, because I don’t what that to happen :wink:

Can’t you just install the non-beta through the appstore? I think it will overwrite your current beta-app without removing the settings (and authorisation).

@Fire69 You are correct. That’s what I’ve did and it’s worked fine.

Just waiting on the image grab functionality to be added

Installed sucessfully the latest version of the app.
Hopefully soon more functions. I would like to snooze by a flow.

Super work! Can I install it from github?

No, this version is not on Github

Wow! That is indeed great! I’d love to install this too.


Why not put it on github? Easier for everyone.

Because I just made changes to the version maintained by @denniedegroot. If he is fine with it he can receive a pull request and can merge it.

Can you share how it should work? (tried removing and readding the Video Doorbel too)

I’ve got the following (bad DU -> EN translated):

Flow 1:
If: motion sensor is activated
Then: get current snapshot

Flow 2:
If: Snapshot is collected
Then: ?? Cannot seem to do anything with it… or am i just mistaking?

Edit: How rude; thanks for picking this up! And really big thanks for setting the beta version number a bit higher than 2.1.1 :wink: no need to remove my authorization.

Right, let me know if you have a new version… i’ll test right away.

@denniedegroot made a new beta version with image grabber fix so please ignore my posts about my version.

You are late… There is already an update which fixes the image grabber on the beta branch

1 Like

Only better if he fixed it :slight_smile:

1 Like

It’s fixed and it works!! Thank you everybody who’s involved in the realization.