Ring Doorbell app

I should download the Ring Doorbell app (https://homey.app/sv-se/app/com.ring/Ring/), but it seems removed? Someone who has a clue?

Yes, issues with 2fA. But use search for a solution.

A bit of search and you find the answer straight on that Ring has forced 2FA and the Ring dev app has withdrawn his app.

See here for a solution that works 100%.

1 Like

I haven’t tried it but it looks like https://github.com/kaohlive/com.ring is a more polished version than my hack.

1 Like

I’ve been using the official Ring app from the App Store for a while now and all has been great.

Over the last few days none of my 4 cameras are detecting motion, the cameras are working fine using my Ring iPhone app but my homey app isn’t picking up on motion.

Has anyone else seen this or should I use one of the above apps that I think I need to install via CLI.

I should mention that I’ve deleted the app, reinstalled and also reauthenticated but no change.

Which version of the app are you using? I think they have been merged. I’m running version 2.4.0 , the test version.

I’m on 2.3.2, how would I get the test version?

Append the app url with /test

Got it thanks :+1:t3:

Updated to test version but problem still persists, anyone else seeing this

I have exactly the same problem with my Ring doorbell. Last motion detection is 4 days ago. I reinstalled the app, but still the same problem!

Im running 2.3.2 version of the app.

I’ve logged a comment on the developers GitHub

1 Like

I’ve also tried the test version 2.4.0. but still no motion detection in the Ring app.

We will have to wait i think.

I was contacted with this fix and it works

Had the same problem I revoked authentication then changed mfa to auth app and readded a doorbell authenticated with username password and mfa code them canceled. After that everything started to work again

There are some issues in the last week with the Ring servers so perhaps this could be the reason: https://status.ring.com

I have no problem with the (dedicated) Ring app itself, it works great. Only with the Ring app on Homey. If i log in on Homey i see the snapshot/camera just fine, but cant get a snapshot within a flow and no detection at all.

I hope there will be fix soon.

Did u also try to re-add ur Ring after u got 2.4.0?

Had tried it already with 2.3.2. Just tried it also with 2.4.0. Still the same problem. No detection or snapshot when I ring the doorbell.

Nobody else (besides @gy_1977) have this problem?

Mine now working again as per the fix I posted above

1 Like

Hmm I don’t really understand what u did.

Just to be clear:

  1. Revoke authentication
  2. Change Mfa.
  3. Re add ring.
  4. Authenticate app.

I don’t get step 2. When I “re-authenticate” the app i get an sms with a code.

I already tried to revoke authentication and re add the ring doorbell with mfa (new code with sms). Do I do something wrong.

And ur on 2.4.0?