Ring Doorbell Autorisation button not working

Check out this thread Ring Doorbell V2
Basically Ring has broken it.

Ring app is disappeared in the store?

The dev has asked for it to be pulled as it is no longer working since Ring enforced 2FA. It is a sad day.

1 Like

From slack

from what I’ve read, has been removed from the app store on request of the app developer due to recent 2FA implementation by Ring (no direct solution how to implement this at Homey, without becoming a recognized partner from Ring to get access to the API) and the “pleasant” reactions from the app users to the developer…

And

Yes the code used for 2FA is already on the ring github but dennie does not want to support a app that needs hacking every time since a simple solutiion could be for athom to become partner (or implement the changes) themselfs.Who knows another dev that feels up for the challange stands up. Dennie doesnt have a ring device himself so its kinda hard to start testing with 2FA when not having a devices and account for himself.

If people would like to see the app come back maybe you can send a new feature request to Athom https://docs.google.com/forms/d/e/1FAIpQLSc8j_GfID4adV4w5ogNtIX1-AqVWrkgIo3bOjkoNtqlHMM0xw/viewform.

Athom stand a better chance of becoming a partner with Ring than a single individual.
If they get enough request perhaps they will consider it.

With help from https://github.com/dgreif/ring I have managed to get the Ring app to work with the authorisation code that is emailed (forced 2FA).
I am not sure how to share this with anyone that is interested in trying it and I’m not sure I want to take it on even if Dennie would agree to that.
What do people think?

7 Likes

Let me know if you need somebody to test it :slight_smile:

I have forked Dennie’s repository so the modified code can be grabbed from here https://github.com/AdyRock/com.ring

2 Likes

This is great work, many thanks, how do I install?

You will have to install it via the CLI.
There is a tutorial here [HOW TO] CLI install method

1 Like

Very nice and works like a charm, cheers!

1 Like

You are a pure legend! Thank you very much Adrian, my Ring works again.

P.S. You have to give us a link to donate.

2 Likes

Ad, you Rock!
And while we’re on the subject https://youtu.be/evA-R9OS-Vo

1 Like

Hey Adrian, did you just adjusted the English version?

I only added 1 message to the settings screen for the Verification code. I must admit I forgot to check the other language file. Does it cause a problem?
If you have the translation I can add that to the fork.

Can any one translate “Authentication Code from email” in to dutch for me?

Authenticatiecode van e-mail

1 Like

Great work Adrian, thx now It works again :partying_face::+1:

1 Like

I haven’t tried it but it looks like https://github.com/kaohlive/com.ring is a more polished version than my hack.

I don’t no why but i am not able to connect to my Ring account. I entered the correct email and password but get the faultcode 401 all the time…

After a 50 times orso it works :crazy_face:

Updated via CLI method but do I need to re-add my devices. I see the 2FA area to include code but the authentication button is greyed out when all info is inputted.