Homey Community Forum

Report unreachable Z-wave devices

I believe I am not the only one having occasional problems with unreachable Z-wave devices. You can easily spot them on developer.athom.com/tools/zwave. But wouldn’t it be nice to be notified by Homey about such malfunctions in stead of experiencing suddenly not working flows? It would be even better to have a repair option in Homey.

Unreachable doesn’t mean it is unusable. It just states that it has missed a request at some time for whatever reason. Mostly the device is working fine. You can try that by using the “Test” function behind the 3 dots on the end. Or, in case of a plug, send a “basic on (or off)” command. In 99.9% of the time it will switch immediately.

If the device is marked “unknown” in the “Route” column it is really unusable.

This is what Athom replied when i asked:

A useful correction. Thanks. Still, I have unusable devices at least every month. A notification would be very useful.

Then define unusable. Empty battery? Do you have to re-pair? Or are they working again after pressing a button?
You might try the “A device hasn’t reported” trigger card, but that only works if the device stops responding to Homey completely.

I agree it would be useful to have flow cards:

  • Z-wave device hasn’t acknowledge command
  • Send z-wave “Test” command
  • Heal device

And generally everything which is available in developer tools panel should be available via flow cards.

What I meant with unusable is not responding to commands from Homey (either directly or in a flow). The most common solution, for wall plugs, is to remove the plug from the socket and re-insert it. Your “hasn’t reported” card might be a very good idea to get notified. I will try that.

What brand are the plugs?

I have Neo Coolcam and Fibaro. It is not only a price difference. With Fibaro I have experienced this problem once. A Neo Coolcam plug typically fails 2 to 3 times per year. In 95% of the cases pull-the-plug works.
Knowing when to pull-the-plug would be nice.

Do you have the latest version of the Coolcam app?
Do you have unknown nodes or strange node numbers in the Z-Wave mesh?

All apps are updated automatically. And indeed I do have numbers in the routing table that are non-existing nodes like 128 and 132. It feels like my Z-wave mesh is becoming more and more unstable. At this very moment 8 out of 15 devices have an unknown route and do not respond. Heal or restart Homey does not have any effect. Pull-the-plug or deleting and re-including seem to be the only options. Usually. For some devices this will be the second time in a few days pull-the-plug is needed.

Ghost nodes generally only appear with unknown devices because the path of unknown devices can’t be determined. Unknown as in removed physically and not unpaired or empty battery so not responding. They are most of the times only marked as unknown after a reboot.

Hi, I did not want to start a new thread so I am adding my problem here.

Everything was working flawlessly before but I have unplugged my homey by accident and after plugging it back in, my z-wave devices are reported as unreachable. Zigbee works.

I can find and trigger them on the developer page - so they are working and are connected. But in the app and web app they report the red “!”-sing and won’t work. I have tried un- and replugging the devices but still no response.

The devices are everspring / technisat sockets and a fibaro roller shutter…

Thanks for any kind of help!

I tried to add another everspring socket but homey already gives me the red “!” for the two sockets that I own in the menu to choose the device from. How can that be?

Did you already try a PTP?

Thanks, yeah, I did. But the ptp was the problem in the first place as the zwave did not work afterwards.

I reset the zwave network and restarted homey. Afterwards I was able to add the devices again.

Then I unplugged homey again by accident (the socket is a bit flimsy due to child protection) and encountered the same problem. The zwave devices were not working and I could not add more of the same. So I reset again and its working now.

Is this a known problem?

How long did you wait after the PtP? It can take a while before all devices are up & running again and the mesh has settled. Or maybe an app has problems starting, preventing other apps, devices or even the z-wave network to work.

I’d say long enough :blush:
Half an hour maybe or even more.

@PetervdK Thank you very much for the hint regarding the app. It turns out that the everspring app needs a restart to work again after having unplugged homey…

1 Like

Hi.
My situation is exactly like yours.
Routes to some devices include unexisting nodes and these devices become completely unusable. Heal does not work. Happens every week. Remove and pair again helps but a lot of work required to restore numerous workflows driving me crazy.

Did you find any solution?
Should we complain to Homey?
Can we activate some logs to find what causes this issue?

Sounds like there’s an active z-wave router in your home that Homey is no longer aware of but that wasn’t properly unpaired?