Re-add existing zigbee device automatically

Hi everyone. I keep experiencing an issue where some Zigbee devices stop responding after a certain period, even after creating the Zigbee network anew according to the instructions, which state that routers should be added first and then end devices from their intended locations.

Whenever I notice this, I add the new device again by holding the button for 3 seconds. It tells me that the device is already added and needs to be removed first. However, I simply restart the app and the device starts working again.

So, I was wondering, is there a way to automate this process? For example, could there be a script that sends a signal to the device once an hour, and if the device does not respond, it indicates that the device is unresponsive and automatically restarts both the device and the app?

Unfortunately there is not. The pairing must be still invoked on the device itself.
There is a script however might might help you to check if device is alive (depending of device type) -

or for Zigbee only

Beware of some specifics, eg. lights, unless powered on, send update in between 12-24 hours, battery powered devices sometimes on external trigger only (eg. motion) etc.

As you are probably on HP19, I would also suggest you to have a look on recommendations (if any) provided by this script :

(might not be however compatible with latest HomeyScript)

That just shouldn’t be necessary in a healthy zigbee mesh, and sounds like a workaround ‘fix’.

Imho it makes more sense to solve the cause of the ‘silent’ sensors issue.

Zigbee is a sort-of-standard.
Several manufacturers use their own flavour, which does not easily work together with devices from other brands, also depending on which zigbee controller is used.

With my Pro 19, Aqara sensors stopped sending updates just like you described.
That started to occur after I added Ikea Tradfri lights.
It seems when a Aqara sensor has started using such a light as zigbee hop, it can’t communicate to the mesh anymore, and it also doesn’t seem to be able to switch to an other hop.

However, these problems do not occur when I use zigbee2mqtt as controller :man_shrugging:

With Homey as zigbee controller:
after I replaced the Ikea lights with Lidl lights, the Aqara’s work 100% fine.

This is just an example.

Most probably some of your zigbee router devices (=almost any mains powered zigbee device) aren’t 100% compatible with some of your sensors, when using Homey as zigbee controller;

Either replace the routers OR the sensors, or migrate your zigbee mesh to zigbee2mqtt

I bought Homey precisely because I didn’t want to have a million different hubs forming my smart home. Now, after several years, I find out that Homey can’t properly (in some cases) unify various products from different brands. That’s “great.”

Anyway, I have one device from IKEA in my Zigbee network, which is an end-device, a switch. Then, I have a Philips light as a router (maybe this is the problem because when I look at the network, many of the devices using it as a router are failing). Additionally, I have one Gledopto router, and the rest are Sonoff and Aqara devices.

While writing this comment, I noticed that my routing has suddenly changed, and the mentioned Philips light is no longer used as a router and has been replaced by the Gledopto. So, my question is: is it possible to disable certain devices from acting as routers?

Unfortunately not

Why are you just not honest to people asking questions and tell them Homey itself is the cause there IS no healthy Zigbee environment?

There is a known Zigbee issue that for many keeps throwing out zigbee as a whole.
See last stable release note

If you have an IKEA air Quality zigbee device, I was told in pursuit of my legal case that that one caused more issues than others. Worth a try. Of course they didn’t bother to inform anyone else.

Just be aware information is limited, issues remain unresolved, and Homey has been more than overtaken by prebuilt Home Assistant boxes for half the price.

There, indeed if you want for some reason to readd a device, just pair it again and all the automations keep working.

Get out while you can, I did.

Excuse me? I’m honest, but I try to keep in mind this is a Homey forum, not a anti-Homey forum.
I think it’s not classy to tell everyone: “hey ditch Homey, and go use zigbee2mqtt, and all of your problems are gone”, before trying to solve things first.

And I’ve had my share of grey hairs with z2m as well, if you believe me, which I doubt :rofl:
Nothing is 24/7 100% perfect, believe it or not.

Also, with my Pro 2019 I had no issues with zigbee, except for the Ikea - Aqara ‘clash’.
So to me, you are not honest to write just this:

Yes, I moved my zigbee to z2m out of curiousity ánd because of the support for much more devices, and way quicker support for the latest devices. I’m very happy with it.
When folks ask me if I know a better zigbee implementation than Homey has to offer, I’d be happy to tell it’s z2m.

I had your account muted, but I was curious if you had some useful info. Not. It’s going back to mute I can tell you. You seem to think you are hired by HA appearantly :nerd_face: