How to delete a not existing Zigbee device

How to delete a zigbee device that doesn’t exits any more on the network.
When I try to delete it, the systems ask to set it into learn modus. Thats not possible any more.

Just keep it on the screen where it says to put it in learning mode longer. It will time out and the device should be gone. Can take a couple of mins.


1 Like

Thanks, that worked after the second try.

1 Like

Well… I’m trying everything unfortunately that doesn’t function in my case… Happens mainly with Xiaomi devices… Time out isn’t appearing unfortunately…

My xiaomi network is instable, sensors are dropping their connection… I am working on a solution:

  • Ikea Tradfri Lamps on the Philips Hue network (kids are using the on/off switching on an of sometimes, and than “routers” are missing
  • Xiaomi sensors (over 40) directly on Homey… but since this is either too much or the house is too big I added 5 Trafdri control outlets to function as router

B U T since I am not able to delete devices this plan doesn’t work :frowning: suggestions are more than welcome

I had the same issues and decided to reset my Zigbee network. Its quite a task in some cases but I did end up with a new solid Zigbee network. Also make sure you dont have old or non functioning devices lying around. Or at least take out the batteries.

1 Like

That’s my horror scenario with over 40 items… And but and euhm you mean “resetting” does delete all devices also?

Yes resetting will leave you without any zigbee devices. You can then start the fun job including them all again. Took me about a day to get it all up and running again.

Still doubting :slight_smile:

I also ran into a similar problem. I deleted a Xiaomi sensor from the devices screen because I had some troubles with it and wanted to try if re-addding solved the issue. But after that I kept getting an error saying ‘duplicate device’. In Homey’s developer tool the device was still present as well. I had to open the Xiaomi app from the settings screen and there the deleted device was still active for some reason… After I removed it there it was really gone and I was able to add it again. I don’t know if that was a bug or something but maybe this will also do the trick for you?

In the developers tool there is also the possibility to remove the device, scroll to the right there are three dots. Push the dots and sometimes you get the remove possibility.

How is the soluties coming? I’m curious… I’m using only two Xiaomi magnet sensors. In combination with just three Ikea-tradrfrfiri bulbs. And even my zigbee network grinds to a stop every 24hrs…

I get an:

Let’s not confuse the people with zwave vs zigbee.
This topic is about removing a zigbee device(s), so let’s keep it this way. (there is no 3 dot menu for zigbee, and zigbee has no nodes)

1 Like

Hello Community,

does anyone know why Homey finds a duplicate for brand new devices?
How to delete a Zigbee device when it is not available in the devices list?

And of cause not the right topic but: Why is Homey Telling me that Zigbee installation is already running, although I restarted Homey?

Looks like Zigbee is not really stable in V2


I don’t know if this is the solution anyone is looking for, but I recently ran into a similar problem with one of my Osram Smart+ plugs (these things are real pieces of work sometimes) anyways, one of them broke and couldn’t be connected to any Zigbee network anymore, and also couldn’t be removed from homey (even though I left the app sitting for ages). So I did some tinkering and came up for a solution for my problem (and maybe others, who find this post)

  • First of all, disable (not uninstall) the App associated with the device temporarily (this shouldn’t mess anything up, just don’t touch anything while the app is disabled)
  • After that, the device should show up as faulty/broken/unable to connect.
  • Remove the device (this should work instantly now, no loading or unregistering shenanigans)
  • Now the device is no longer visible inside the app, but if you look inside the developer overview (under zigbee) it is still listed as enabled, but unreachable.
  • To fix this, simply Re-Enable the App and reboot your homey (I rebooted through the button inside the app)
  • After that, reload the developer page, and the device should be gone, and all Zigbee networking should rebuild within a few seconds and continue to work as if nothing ever happened.

Hope this is helpful at least to some who end up here when encountering Zigbee routing problems


I have a really annoying problem with my zigbee network. I have about 50 zigbee devices and about 20 of them are Aqara motion sensors and door sensors. Sometimes Ikea smart plug stops working and I need to unplug it and then plug it in again, then it works. But the real problem is aqara, the sensors stops working randomly and I need to remove them and add them to homey again. Can a zigbee reset fix this?

OttoWerse - How do you disable the app?

Start Homey app / Click more / Click apps / Select the app / Click the cogwheel upper right / Select “Disable”?

Tnx! This worked for my.

I had the same problem als @victoroos. Now I’m finally get lost of this anoying device :slight_smile:.

1 Like

Thanks, that helped!