Can't remove Zigbee device

So when first setting up I tried to get the IKEA 4-button dimmer connected as a Zigbee device. It didn’t work, and I later got it integrated by using the IKEA Bridge app.

Later I discovered that the device I created was still in the UI.

I’ve tried to remove it through using the remove function. This did work with some other Zigbee devices, by waiting for it to time out. For this device, however, it never does. It gets stuck on status.scould_not_find_zigbee_shepherd_device

The other way I’ve tried to remove it is by resetting Zigbee. I don’t have any devices connected through the native Zigbee, so no harm.

But when resetting, this message pops up;

Is there any way I can remove this device from Homey?

Edit - I have searched for this topic and can’t find the answer.

Did you try the (excellent) search function?

If you really can’t delete, you might try this:
First restart your homey. (PtP)
Then go to: more (tripple points)
Click on ‘apps’
Wait until your zigbee app is started.
Then directly click on the app name and look for the device you want to delete, click and hold that device until it’s screen apears.
Then you can delete it via the configure screen (gear icon on top right)

And, after that, read the post from Peter above the post from Hugo.