Can´t add any new Zigbee devices

Hi
I have 23 Zigbee devices, 5 Ikea Plugs direct connected to Homey and 18 Battery devices. The routing working so far but suddenly I can´t add new devices. I have tried with Ikea plugs and Aqara temp units.
When i start the pairing on Homey and set the unit it pairing mode nothing happens. I tried with several plugs and temp devices both as generic Zigbee device and thru Ikea and Aqara app.
But can´t get any response from the pairing.
The units that´s are added before is still working fine.
Do anyone have a guess what to do ?
I had restart Homey but haven’t reset Zigbee, and don´t want to do that.

Are the new devices ‘new new’. Maybe they have new Id’s which are not yet known by the Homey app.

If you look at Advanced Settings and check the ProductID, DeviceID and ProfileID of your currently working device and the same new device. Sometimes vendors make new versions that get new IDs

For example:

I have tried with both new new and older devices that I haven’t been using for a while. I will check the ID later today.

Not the first and for not the last with this. Guess a few 100 topics about it :wink:

Should be solved when the zigbee rewrite is done… and please dont asked when its done :rofl:

For more info… try the search

1 Like

The 20-device limit is a hardware limitation, not a software limitation, so it won’t be solved with the Zigbee rewrite.

Instead, some careful planning of your Zigbee network might be necessary, which may require a reset, or at least removing some of the already-paired battery-powered devices to make room for more (always-on) router devices.

That way, a proper Zigbee mesh can form and new devices will be routed through one of the router devices instead of connecting to Homey directly (which also means that if possible, add new devices from their final location instead of having them close to Homey during pairing).

After adding (one or more) router devices, allow for the network to settle, which may take about 10, 15 minutes, before adding battery-powered devices.

3 Likes

Thats why i have 32 zigbee devices conneted in the past, for testing and yes it did work :rofl::rofl::rofl:

All directly connected to Homey as controller devices (and not through router devices)? Because that’s the issue: Homey’s hardware has a limit of 20 directly connected devices. That doesn’t mean you can have only 20 Zigbee devices being managed by Homey in total, it means that when 20 of those devices use Homey as their “parent”, you can’t add any more devices to Homey directly anymore. Exactly what OP is experiencing.

So with

I assume he means connect with homey instead of using another bridge.

1 Like

Yes, so some battery devices are being routed through the plugs instead of being connected directly to Homey. And Homey isn’t accepting new devices being connected to it directly, which very likely means that it has reached its 20-device limit and the only thing to try now it to try and pair new devices as far away from Homey as possible, making them try to pair through an existing router device instead.

Try This app
I have added a lot of Phillips hue

I’m in the same boat. I have 23 devices including 2 innr SP120 routers, but I can’t add more. 2 devices are routed trough the routers, the rest direct. I also really don’t feel like resetting the network and have to re-add everything and fix all the flows. With 2 routers it should be possible to have 60 devices…

In an ideal situation perhaps, but Homey cannot enforce devices to use routers. You need more router devices if you want build a proper mesh, which means that you probably need to remove at least some existing (battery-operated) devices from Homey first before you can add more routers to the network.

i must be lucky for once. i have 18 devices now and only to are NOT connected thru a router. So i hope i can add some more :slight_smile:

1 Like

(I have no issues with zigbee…) But more of curiosity, how did you pair your devices? At the final place where you want them to be? Did you move around your Homey?

i started with the routers. 4X innr lightbulps and 4X ikea light bulps. After a few months later i added some of the end devices. So yes i had i nice network before adding some of the switches enz. And i must say that also the range of the end devices is great. Don’t have a uge home but nevertheless the range is just fine. The only one thats giving problems is the temp sensor in the fridge.

And the end devices, did you pair them close to Homey or at their final place?

To be fair, I am not quit sure. But I think both

Hello all, my first message here. I hope someone can advise me. I did quite some research on the forum when I was unable to add additional sensors I discovered that it has to do with the 20 devices limit (check, learned something!).

Because I’m building a mesh / network from scratch the first 16 bulbs are my driveway/garden lights. I had the idea that they are all far away from my homey, so I took one of them and lighted it up inside the house (as the only lightbulb / router currently in the house). After that I was able to add one additional temp sensor, but not more devices, so the problem still excist. I checked the Zigbee table and I see that, according this thread, I should be happy with 18 router devices in my 24 total devices. I see that one of the end devices is connected to a router device. But nevertheless, I cannot add more devices. This is the Zigbee table.

Something that i’m in doubt with. I read the queston before, but without an answer. When pairing the new device, should you do that close by the Homey or close by the router device, so that it uses that as his access point to the mesh. I assume that Zigbee is managing this by itself… Can someone point me towards the right direction? Do I overlook something? Thanks a lot!!! It’s an Homey Pro that I bought a month ago.

Lot of routers, but as you stated only one in the house… that wont give you a good mesh in the house.

The 20-device limit applies to both routers and end devices. If you have (almost) 20 routers that are directly connected to Homey, you will hit the limit as well.

What may work is to add (end) devices at, or at least close to, their final location. That way, the device will hopefully join the network through a router. Some devices don’t “jump” routers and will prefer to use the router they initially used to join the network, which may not be the most logical router in the mesh.

Also, it may work to completely turn off a few of your lights when adding new devices, hopefully forcing those lights to pick a router when they get powered up again.

And also take note of what @RoyWissenburg says: having lots of routers close to each other doesn’t necessarily make good coverage for your entire property.

1 Like