Qubino Smart Plug does not show Current usage

I just did install a Qubino Smart Plug 16A on my Homey.
Now i am able to switch On/Off my device, but in the Homey app the current usage is not being displayed (just shows “0 A”)…

I have also a Qubino Smart Plug 16A and it is also not showing any power usage on the tile
But in the app Power By The Hour, there is the used power showing well for the hour, day, month and year.
Remove and re-add the device did not solve this problem.
I have another one that is working ok. It shows his current power.

1st thing which pops up: Did you select the current power status indicator?
Else try selecting an other indicator, save settings, select the current power indicator again and save settings

In fact i did receive 10 pieces of Smart Plugs…
When i removed the devices from the app and included them again, most of them now seem to work OK, but with 1 piece i still have problems.
I must try to include it several times and, despite your hint to change the power setting to Amperes, i does just shows “0”.
…And the plug’s response to switching it ON and OFF is very slow… Sometimes even 15 seconds.
I therefore decided to return this 1 piece to the supplier.

I guess it’s more a Homeys (App or Z-Wave core) problem than a problem of the Smart Plug. I use several Fibaro Walli Switches and some are showing the current usage and some are not. I excluded and included them already, but nothing changed. I connected Athom several times already, but it seems that this bug is not on their priority list.
So I recommend to contact Qubino, because they are the developer of the app. Hopefully they get then in contact with Athom.

Delay’s up to 15 sec are definitely not ok. I guess it’s a problem caused by excluding/including the Smart Plugs several times.

  1. Carry out a PTP
  2. Have a look into Developer → Z-Wave if there are „Unknown“ devices. If there are „Unknown“ devices, delete them and restart Homey. Then wait some hours and try again, if the delay is still there.