Looking for a heavy duty power plug


Currently I have some Qubino Smart Plugs, which can measure power up to 16A (3680 W). They work over Z-Wave. But the problem with these Qubino plugs is that they lose connection with Homey every once in a while. Since they are mounted at hidden locations, it can be hard for me to remove them and reconnect them to Homey.

I use them to measure the power of my dishwasher, my washing machine, tumble dryer and my oven. These are devices that can use a lot of power, so I guess I need at least a 16A power plug to measure the power.

I’m a little afraid to use Fibaro Power Plugs for this application, since I expect that these plugs will not be able to handle this amount of power. Or can anybody tell me differently from their experience?

Now I am looking for new smart power plugs, that are able to measure up to 16A. They could be either Z-Wave or ZigBee, but not via Wifi. They should at least be able to measure power; in my opinion measuring voltage is not necessary (the Qubino’s are able to measure this).

Preferably sold in the Netherlands, with a maximum price of around 60 euros.

Isn’t it possible to add an extra z-wave plug in the middle of the devices so the mesh will get more stable?
I use a Z-wave plug on the first floor and on the second floor I use a Qubino plug (3680W) and it never has lost his connection?

I have a pretty stable mesh IMO, over 50 Z-wave devices, mostly Fibaro power plugs, Fibaro single/double switches and Fibaro dimmers. But also these 5 Qubino power plugs.

The Qubino plugs have been causing trouble since I moved from Homey Pro 2019 to Homey Pro 2023. The Fibaro devices never gave me as much trouble on HP23.

Are they really losing the connection, or are they not updating the data anymore?
BTW, before I would invest 300 € for new devices, I would first contact the support of Qubino if you haven’t done it yet.

In the developer webpage, they show as ‘Unknown’ route. And yes, they are not updating the data anymore, or can be turned on or off (but I never turn these devices off). When I test them, they are also unreachable.

Ok, than they lost their connections. Have you checked if a new firmware is available?
A FW update can be done with an Aeotec Z-Stick Gen5(+) and the Aeotec Homey App without deleting the Qubino Smart Plug from Homey (instruction).

Btw Aeotec. From Aeotec there was once the Smart Switch 6 also with 16 A available, but this plug is end of life. However, it may still be available.

Just as info regarding my first question: I have the Qubino 3-Phase Smart Meter in use and I have to send every 5 minutes a Z-Wave basic command, otherwise the data would no longer be updated. When this happens the device is still connected but the data are “frozen”.

As I already suggested, I would contact Qubino. They have also a own forum topic (link).


A firmware update sounds logical, but I cannot find any firmware version, nor if the firmware version I have is outdated or not.

May I ask what basic Z-Wave command you are sending? I think this could be very useful for me as well, if I am not able to find a firmware update maybe this will keep my Qubino’s alive (after I have re-added them this weekend).

I contacted Qubino already a while ago using that forum topic, I think the next step will be to contact them from their website.

You can find the FW version in Developer Tools → Devices:

Or, if you’re already on Homey FW v10.0.8, in the advanced settings of the device:

However, it could be that no information is available. According to my observations, Athom added the possibility of displaying the FW data of a Z-Wave devices with a Homey FW update, which was released about 1 - 1,5 years ago. All devices that were added before this Homey FW update don’t show any information.

This is the link to Qubino’s tutorial on the 3-phase smart meter issue.
In short, this is the Z-Wave basic command which is send every 5 minutes:

0x20, 0x02

(215 is the NodeID)

There is also an email link in the App Store:

I also did mailed a time ago to Qubino and did get the new firmware and a gif file with a step by step explanation how to update. My pug wasn’t updating the power totals so they give me the tip to make a flow with a raw command.
And that worked fine.

Any chance you still have those instructions and the firmware file, and can send them to me?

I don’t know if I stil have them but it also depends on the type of plug and the firmware what is now on that plug they say.
If you send them a email you get an answer in 1 or 2 days with the correct answer and firmware.
I will have a look if I can find it, but it is a small chance.

I considered using this one

because I had burned a Fibaro wallplug for a large inline bathroom duct fan.
It has an inductive load and apparently the fibaro couldn’t handle it. Power is only about 50 Watt, but the switch on peak current becomes too high. The first signs of failure were intermittently loosing connections. After a few days it failed completely. Also removing and trying to add as new device did not work, so indeed the fib plug had died.
I also burned a Tuya zigbee plug this way.
My final solution is using a qubino mosfet dimmer instead of a relay based switch. The dimmer can be operated as a switch, and because it has slow start and slow off, there are no peak currents.
The dimmer can handle about 200 Watt, so this will not work for a dryer, dishwasher etc, I would try the POPP.

Other option would be to use 2 devices : one for metering and one for switching. For the switch you can then use a heavy duty relay with no metering, the metering can be done eg with a DIN rail zwave meter or a fib/qubino plug that is always on. But that is a more complex and more expensive option.

With 2 years of warranty, the POPP is worth a try, with the FIB’s I did not get any warranty, burned several old school behind-wall units when transitioning to LED lights.

Try these:

Shelly Plus 1PM

Can you please first read the content what it is about before you make any suggestion!

You mean: https://www.shelly.com/en/products/shop/shelly-qubino--wave-1-pm

Yes, thank you!

Now it’s Z-Wave instead of WiFi, but still no plug. :wink:

1 Like