[Pro][Dashboard] SmartDash - a dashboard for Homey

I’m working on a blog post :slight_smile:

→ Sonoff
→ Installation
→ Small launcher
→ Proximity sensor/wake up mode
→ Smartdash
→ Bearer Flow for old homey’s


Let’s hope Homey don’t change anything

v 0.240212.1

  • Added dutch language @Ralf_Groot
  • Fixed autoswitching restart: now if you click a button the timer restart (actually work only for some buttons) @Kringloper

some tiles have a minimum size of 0.5x1, others can not be smaller then 2x2?
Why that? For many tiles 0.5x0.5 would be a good value, so if it´s scalable, why not the same size range for all? :wink:

Hi, this because in previous version don’t have options for resize fonts, now it can be obsolete…
I can unlock the sizes


v 0.240214.1

  • Unlocked all sizes for all widgets. @Thilo need testing
  • Added size 0.5x0.5

v 0.240215.1

  • Fixed bug into measure_power capability
  • Fixed some visualization for new widget size 0.5x0x5

Hi, works fine!
Two Little remarks: next row allways starts at the bottom of the highest Field, so you cań t put 1x1 beside a 1x2.
And is ist possible to place the #settings under the page to hide it from users?

for the second question is possible to make it.
For the first is not simple make it automatically (i tried but i don’t find a definitive solution): a solution is with manual position of widget.
I’ll try again, maybe I’ll find a good solution!

Not ideal, but when you keep the “longer” widgets to the left you don’t get holes in your dashboard.

i’m find a solution:

CASE 1: current grid system

CASE 1: alternative grid system:

CASE 2: current grid system

CASE 2: alternative grid system:

The new grid don’t leaves empty spaces.
To recreate the previous version i need to insert a dummy widget for filling empty spaces

v 0.240216.1

  • Added new dashboard grid system @Thilo check this
  • Added dummy widget for fill empty spaces

Hi Julien,

I hope your blog post will help me with the latest steps. SmartDash is working fine on my smartphone, also with HP2019 bearer flow. The next step is installing the dashboard on a NsPanelPro.
After installing SmartDash apk (10244.apk) on my nspanel Pro, I can logon using the http://Homey_IP-adres and a bearer token/api key. But after filling the token url and/or CloudId and restarting the app, only this screen is shown.

Ralf, try to add cloud id and loggin with cloud button. For local have you added the port (80)?
Other test…Skip first insert of ip and token and go into setting section and add ip and token

I did that allready try to fill it in in the settings page. Also adding a port to the Homey url doesn’t help.
There is no possiblility to choose between local and cloud when starting the app on my nspanel pro

I filled the same things as on my smartphone.

for this skip infos and go into setting section, now you have cloud_id

have you tried to export smarphone backup and import it into ns panel?

1 Like

That’s right, but the Homey ip-adres is still required, otherwise you can’t save the settings.
But restoring a backup worked!!! :slight_smile:

1 Like

I ask you to do these checks to understand if it is a problem with the app. With emulator i don’t find problem, need to check with a real device!
Unfortunately, many changes can introduce many bugs