Philio / Zipato PAN04 switch values incorrect in Philio app

Hi, I am having big troubles with this double switch from Zipato / Philio using the Philio app (@Robin_van_Kekem). I can add the switch and it will create a 3 devices, switch A / switch B and switch A&B combined.

How it SHOULD work is as follows. If you press Switch A, it should obviously enable switch output A but it will also enable the A&B one. If you press Switch B, it should enable B, and also here A&B which acts as a ‘total’ device for power etc.

What actually happens is really strange, it seems that there is some kind of mix up, because when I activate B, also A gets activated. When I manually activate A&B, also A gets activated, so it seems the the switch values have been mixed up…

This is basically confirmed here:

Where the switch values should be 1 for A, 2 for B and 3 for the combined one, it seems to be setup as 1 for the combined, 2 for A and 3 for B…

Is there any way this can be fixed? It quite unusable at the moment…@Robin_van_Kekem, please assist. I was very happy with the Philio app, but this is quite the roadblock for me ;).

Unfortunately no response yet, hope @Robin_van_Kekem can take a look soon, the switch is not really usable at the moment because of this issue… Thanks.

I have the same switch with the same problem.
I came from domoticz and there the switch worked just fine.
Yesterday included it with homey.
Get 3 switches and see at the advance properties that the switch controls relay 1 and relay 2.
When I want to change it the philio app crashes.
Switch not usable now

I sold it, and bought a double Fibaro…

Same issue. Philio PAN04-1B is installed all over my house as this has for years been my favorite wall switch.
Just started migrating from Vera Secure and now I can’t control wall sockets and lights.
Any idea when this will be solved?

…and 5 min later I found the solution.
Default settings on device is wrong.
Simply change “Selected Relay that can be controlled” under Advanced settings.

Still. would have been easier if the default values had been correct from start.

But when I changed the relay switch my philio app reboot.
And I could not change it.