Official IKEA Trådfri vs IKEA Trådfri Gatway App

What’s the difference between these two Apps?

  • Official IKEA Trådfri App
  • Unofficial IKEA Trådfri Gateway App

Yesterday I replaced my WeMo, Hue, and Eve outlets by IKEA Trådfri outlets. My main way to control these outlets will be HomeKit (and IKEA’s App). It would be nice if I could also control these devices with Homey (like I could with all those other brands).

I downloaded the official IKEA Trådfri App, but it looks like that App requires me to pair the outlets directly (using a paperclip on the outlet, totally different then the official IKEA App on iOS, which uses a remote control) to Homey, losing the HomeKit connection.

This morning I tried the unofficial IKEA Trådfri Gateway App instead. This seems to work!

Of course I would prefer to use an official (Athom) App when possible. Is that possible for my use case?

The difference is that with the “official” app (the one created by Athom), your IKEA devices pair directly with Homey. They become part of Homey’s Zigbee network.

The “unofficial” IKEA app (the community-created one) interacts with the IKEA gateway to handle your IKEA devices. That means that those devices a part of a separate Zigbee network. You get to keep all the advantages of the gateway, like grouping and binding, which Homey doesn’t support (and, AFAIK, also won’t be supporting in the upcoming firmware v5). The disadvantage is that your IKEA devices are not part of your Homey Zigbee network, and as such, won’t help extend it.

Because the gateway app maintains all the gateway features, your can keep on interacting with the gateway using Homekit. With the “official” app, you have to enable one of the Homekit implementations for Homey if you want to expose your (IKEA) devices to iOS.


Thank you for confirming/explaining!

For my use case I will continue using the Gateway App.

Would any of the two app be able to connect to on/off switches ?

If you mean this device:


The “official” app will support this on firmware v5 (which is, as of yet, still experimental); the “gateway” app doesn’t support this device directly, but you can pair it directly with other IKEA devices (for instance light bulbs) to control those devices both from the switch and from Homey.


I have now updated to exp. ver. 5 - and reinstalled the officiel Ikea App. After this I am trying to install a few appliances (Dimmer, 2button on/off and 5 button) - but in all cases when I am trying to pair, I am requested to tap link button a few times but it never gets any further in the pairing

Have you installed the specific v5 version of the app (this one)? Also, the experimental v5 firmware has known Zigbee issues…

Now it works - I was not aware of the experimental version of the App. Is there an URL to this, and other experimental app as I really want to get my smarthouse ‘fine tuned’ :slight_smile:

Okay, seems to be a billion Tradfri threads and can’t find an ‘official’ one for the app so going with here…

Has anyone had any success connecting the signal repeater to the direct app (not the gateway)
I’m trying to do it, but the instructions say hold down the button until the light flashes… it never flashes. If i release it starts doing a wierd flash, but that doesnt seem to connect and it stops shortly after

Looks similar to my issues connecting the Control Outlet (Homey 4.2.0, Official App)

Not sure exactly how I did it, but holding a paper clip to the “button” for a quite long time, and then adding it in Homey app, it somehow ended up being paired after a while.
Sort of more following the IKEA instructions in their manual, and not Homey app instructions.

Thanks. At this point I’ve tried every which way I can think of!
The IKEA instructions say reset for 5+ seconds then start connection but that’s it…
I’ll try a very long time holding but I’ve already done 1min!

Nope. This is a bloody joke… I must have wasted an hour trying to press this little button in every way possible…

Right, so now I’m sure either the IKEA app doesnt work, my homey is broken or something else is going on…
I’ve taken the blind off the wall, (decided to forget the repeater for now), and trying to connect the blind directly. It’s right next to homey, flashing as described, but it will not connect. I just get timeout every time

Can anyone help me here? Please…

Edit. Also just confirmed I’m still under 20 battery devices (not that it should matter since I’m trying to connect a signal repeater).

Edit2. I have just removed a device ‘just in case’ was hitting some kind of limit… no difference.

The limit is for 20 directly connected devices, doesn’t matter if they run on battery or are mains-powered. Removing a single device may or may not fix issues related to hitting that limit.

Have you tried another power supply already?

Given the state of Zigbee on v4, you should probably either wait for v5 to become stable (or take the plunge and install the experimental version) or move to a completely different Zigbee controller. If Zigbee were really broken the rest of your devices wouldn’t work either, so I don’t think it’s a hardware issue.

Why would removing an item not solve this?
I had 20 devices including Homey so I should have space for one more. Would be nice if it advised of this limit…
Now I’m down to 18+Homey so definitely should be space

What do you mean by trying a different power supply? It’s been in a few different places

Is there any way to force using a router? I have one in between a bunch of devices and homey but doesn’t seem it’s used

Because removing a device changes the network, and you never know in what way it changes. If you only have 20 devices in total it should work, but I would a least do a full reboot of Homey after removing a device to make sure it’s properly removed from any internal tables.

That’s bad marketing. Athom’d rather let people find out themselves that Homey is limited in that respect.

If you’re still using the original Athom power supply for Homey, change it for something else. 5V and 2A minimum of a decent brand should work. The original power supply is crap and can cause random issues.

No, you can’t force that. You can try pairing the device closer to the router and hope it uses the router, but no guarantees. With the v5 firmware, you still can’t force a device to use a router but according to lots of users that are running it, the mesh network is much better (if it works, some people had to do a full Zigbee reset after upgrading to v5 to get their Zigbee working properly).

I’ll try removing a few more and see what happens… would rather wait full the verified release given the issues i’ve seen with RCs in the past

Do all Zigbee controllers have the 20 device limit? Or just a Homey issue?

Ah, I changed the power supply long ago as running of a UPS

The Zigbee chip that Homey uses is rather outdated (originally from 2009 I think). Since then, plenty of alternatives have become available that aren’t as limited.

1 Like

Hmm… thanks. Another nail in the coffin perhaps…

I have now removed 2 devices, rebooted and still unable to add the signal repeater… I’ve tried both directly next to Homey and directly next to one of the router devices with nothing being picked up at all as far as I can see…
Don’t really know what to do now…

PTP maybe?