Normal push notifications are silent on Android

My phone is a Galaxy S21, and the Homey app is version 8.0.2. Homey Pro 2023, but the issue was there also on the old Homey before I migrated.

I’m having an issue that normal push notifications generated from a flowcard have no sound. The phone vibrates when the notification is activated, but there is no sound. Sending a push notification with morse (not something I’d actually use, but I tested it now) also just cases vibration (with the correct morse pattern), no sound.

What is weird is that if I generate a push notification with an attached image (from an IP camera), there is both sound and vibration, so there shouldn’t be any permissions issue (all permissions are on, and I even tried disabling and re-enabling them again, but that made no difference).

Has anyone had this issue, and found a solution?

Go to Android app settings for Homey App.
Select “notifications”.
Scoll down to “categories”.
Select a category (on the left, not the toggle button).
There you can choose independent settings for categories.

Nothing has changed. This are Android user settings. So perhaps you changed something accidentially.

No, I did not. All categories (there are four on my phone, Image/Text/Vibrate and TSLocationManager) are turned on, and always has been on.

I deleted all the app data, which basically is the same as a reinstall, and that fixed it.

However, the normal push notification and the push notification with an attached image has different sounds. Probably always was like that, but I have no idea why.

Interesting… I never change sounds,
So I just checked, and the all sounds are the same: “Standard Sound”, except for the text-notification, it has a “Sound delivered by app” setting.
I’m on app version 6.x, but I assume they didn’t change the sound settings on v8.x

Aha. I didn’t actually go all the way into that sub-menu (it is easy to forget that even if there is a slider button on the right side, pressing the line itself gets you into a sub-menu), so it is possible that somehow the text notification had been set to silent (not on purpose), and when I wiped all the data to start over, I got all the default values again.

And now you also explained why that sound is different, it is simply because Homey for some reason decided to have that as a “Sound delivered by app” instead of the standard system sound.

Now I only have two categories as well, “Text” and “Image”. The other two (“Vibration” and “TSLocationmanager”) have disappeared, not sure why.

1 Like


Yeah they become available after the first notification.

No clue what’s the reason, I also can’t find a sound setting for text-notifications from within the Homey app.