Homey Community Forum

Push Notifications doesn't work anymore

Last night firmware 2.0.1-rc.2 was installed, and i noticed that i don’t receive any push notifications anymore. Are there more users having this issue? I recreated the flow, but no luck!

Never mind!!! A reboot fixed the problem!

I am not on 2.0, but experienced the same yesterday.
I suddenly didn’t receive any notification anymore. Testing some flows acknowledged that. My wife still got them, i didn’t. Luckily it appeared that re-choosing the mobile in the flows solved the problem so that saved me from recreating all flows.
No idea what caused it, but i experienced a problem with the new legacy app (it kept crashing upon opening) just before i noticed the lack of notifications. Reboot of the phone solved that by the way.

Same here , after rebooting it works again. Have to reboot it every day now

Hi all. I have a weirder problem. I created 2 flows, one of which to inform me when someone is home while the other to inform me when someone left. However, when using the “Test” button, only the notification for someone leaving works, while the notification for someone arriving does not. Any idea what could be the issue?

  1. Does the flow for arriving run and completes correctly (no exclamation marks at any card)?
  2. Are both notifications are for the same phone?

Hi Peter,

  1. I do not see any exclamation marks at the cards. Furthermore, my testing of the actions are done using the “Test” button (which I assume that homey will execute any actions under the “Then” portion of the flow without the need for any pre-condition in the “When” portions).

  2. The notifications are programmed to go to the same phone. See below:

Can you post the complete flow? I have no issues at all for notifications and messages…

I see i made a mistake. There would be no exclamation mark, but a red cross. See picture below.

  1. “Test” does what it says, it tests your flow including all conditions. So if one of the AND or OR statements isn’t met, it won’t run. Else it should have been called a “just execute” button…:yum:

  2. Sometimes it helps to remove and re-select the phone.

But in your case i think one of the conditions isn’t met and will show a red cross.
For the test you can toggle the true/false checkbox to make the condition meet the current status.
Be sure to save the flow first and also cancel the change after the test.

Peter, thank you so much for your reply. It was really a misunderstanding on my part. I just got my Homey and I migrated from Vera. In Vera, the “test” button does exactly what I assumed, i.e. it only runs the action portion to ensure that it does what you programmed it to do but does not check the conditions. However, in Homey, as you have said, does check those conditions. This is why the notifications worked on one but not the other (which is obvious since they are complementary conditions).

Also, I notice that my interface looks a lot more “dated” than the interface you posted. Is that version 1 of the interface? As I just got my Homey and upgraded to version 2 (which, btw, I hate the fact that everything has to be done via the mobile), the flow programming seems to be extremely restrictive and, unlike Vera, does not seem to provide for custom scripts (Vera allows for lua scripts).


Wonderful! Thanks bvdbos. I will look more deeply into it!

The picture is from the desktop interface, which has been removed with version 2. This is also one of the (main) reasons i didn’t upgrade to the new firmware yet.