Nissan (leaf)


Just a wondering, has anyone been able to integrate a Nissan Leaf with homey?
I’ve been tinkering with home assistant for a bit which had. So would be really nice to switch completely.



I am also very intrestet.

1 Like

I will try that with a Kia Niro Hybrid shortly. It has the UVO Connect system that is permanently connected to the Internet. The car will be delivered in week 10.

NissanConnect EV? Would donate 200euro upfront for an app!

Any news here? I have a Android app working very well (My Leaf)

I am also pay 20 euro upfront.

1 Like

Yeah me too actually.
Have you been successful in finding a solution @Bulletcather?

I am not a developer

I now use this with mqtt and a virtuele devices

I started on basic support for Nissan Leaf vehicles produced prior to May 2019.
Project: GitHub - maccyber/homey-nissan-leaf: Adds support for Nissan Leaf pre May 2019 in homey

It supports the current battery status, charging statuses, start or stop climate control remotely and remotely start charging.

I have owned a Homey only for the last couple of days, so I’m not familiar with the SDK, UI, device or capabilities. So any help would be appreciated :slight_smile:

Nice! Are you going to publish it to the Homey app store?

@Jonas_Enge I tried installing your app and adding a Nissan E-Nv200 (it usually works with nissan leaf apps) I’m able to login and it finds the car, but I get an error message when I tries to add the device.

@cscheiene: Thanks for trying it out :slight_smile:

I made some changes, so it may possibly work ¯_(ツ)_/¯

I’m at my cottage and away from my homey right now, so don’t have the possibility to test it out myself.
To debug it further I need the reponse from your car API which is logged in the console after starting the app. It should only be shared privately or stripped of the keys sessioninfo, VIN and so on…

I might publish it, don’t now how the process is yet, but I could try.
But I probably wont have the time to maintain it later on.

I tried 1.0.7, but it gives me the same error. I sent you the logs, tried to remove the private info :grimacing:

Have you got it to work? Tried myself and got the same error. Might try to experiment where this error comes from if @Jonas_Enge doesn’t know.

No, unfortunately not. It would be really nice to get this working. I have sent some logs to @Jonas_Enge but have not heard anything back

Ok, I will have a look at The code and see if I can figurer it out. Have you had a look at the code? Would be Nice if we could get @Jonas_Enge to post what the response should look like so we can compare it.

1 Like

No I have not. Let me know if there is anything you want me to test.

Ok, I had a go at the code and tried the leaf-connect directly to see what kind of response I got, but couldnt get that one to work either, it throws me and Crypto/Cipher error, so I guess we have to wait until @Jonas_Enge have time to have a look at it.