Nimly Touch Pro - Can't disble AutoRelock

I can’t get my Nimly Touch Pro to take the command Auto Relock Disabled,
This is the flow, that should disable auto relock and keep the door open.
But after running the “Set auto relock to No” the door still auto relocks after 7 sec.
I can see in Homey’s Nimly Pro Touch setting that the flow actually toggles the device tag Auto Relock to disabled.
So now when AutoRelock seems to be disabled, if I just run a Unlock, door should keep open.

But no, it relocks after 7 sec anyway:

( I have restarted and made reset several times)

I also contacted the Nimly Support and got this answer:
“ As the lock is a battery device, it can normally not be reached by Homey for these settings, but only when it is active, for example when being unlocked. This is why we keep trying to apply this setting in the background, but it can sometimes fail all together. Best is to configure the auto relock once. “
And later: “There is a difference between a command and a configuration update: the first is always accepted, the second unfortunately is not. We keep trying to apply the configuration update, but unfortunately there is currently no way to know when the lock does accept the update. Our recommendation would be to create the auto relock yourself in flows, as that is the most flexible option, and to use the auto relock option of the lock only in cases where you always want to have the auto relock configured.”

What if you set the auto relock no before you unlock the lock.

Start → set auto relock no → unlock

and when you want it locked

Start → set auto relock yes → lock

And just before you test that, take out and then reinsert 1 battery.

No, there seems to no way what so ever that the lock takes the setting Auto Relocj Disable.
Can anyone confirm that it actually work?

I did exactly copy your flow, and i got the same behaviour as you.

Then i tried my own flow,and i then also got the same behaviour (it worked before).

Then i did take out one battery and then reinserted it. And my flow again works just fine. Nimly (or Homey?) seems to hold some temp or whatever leftover that has been a problem for me regarding Nimly.
If the battery thing doesnt work on first try, exit homey app, and redo the battery thing, and enter Homey and run the flow.