New Homey Pro 2023 (migration): Z-wave fails to initialize - "Error EAGAIN (6:ioctl)"


I have now tried several ways to get my Homey Pro 2023 to initialize for my first time use but in all cases the Z-wave does not want to start working. Since three years I’ve been using Homey Pro early 2019 (10.0.4)


  • I have tried several times with ample of time in between each step to allow for the backup to restore, apps to be downloaded and devices to be detected.
  • Between each attempt I also factory reset the Homey using the Homey Pro USB tool.
  • In addition to the the attempts to restore from backup I have also tried setting it up as a totally new device.
  • Except ”Hardware region unknown” no other information is available in the ”System information” under Homey developer tools - > Z-wave

FW: 10.2.0

The following has been observed:

  1. Most, if not all, settings seems to have been migrated.
  2. Relevant apps has been downloaded and initiated automatically and correctly
  3. Within about 15 minutes from boot after restore all externally dependant (through apps) devices comes online e.g. Easee, Mill Heating and Power by the hour.
  4. Z-wave never comes online, only referring to “Error EAGAIN (6:ioctl)”

Other actions and observations

  1. I didn´t spend time to repair the Zigbee devices so cannot say if that works. It just says ”Starting” in Homey developer tools - > Zigbee → System information → Current command
  2. In Homey developer tools I tried to manually add EU as region for the Z-wave with a reboot but it did not change anything.
  3. In both as well as in the Android app I received the same error ” “Error EAGAIN (6:ioctl)” everytime I tried to do anything related to the Z-wave.
  4. Couldn’t find anyone else with a similar problem and thus this post might help somebody in the future once it’s solved.
  5. I have submitted a ticket to Athom as well.

Is there something I can do to make it work or is it simply a faulty device?

Thank you for your help!

Best regards

My guess would be the latter, especially if Z-Wave won’t work on a factory-reset Homey (so without any restored backups).

1 Like

Thank you for your reply @robertklep . We’ll see what Athom support says once they look at my ticket. :slight_smile:

If anyone else has some more input on the matter it’d be very much appreciated.

HI, I’ve the same issue. Did you get any useful response from the support? I also contacted support once, but only got the message to start new inclusion of all devices which is a big effort and not really acceptable