New device timeline

Updated device timeline was announced recently - which I think may be super-helpful is debugging the flows as it should show which of them actually changed specific device state. In my case I often find however that the timeline says that device plugin turned it on or off instead of actual flow that did it, or dies not state who changed device state at all - see my screenshot for one of the ceiling lamps, this one is always turned on/off automatically (via flow), but in the timeline you see the relevant flow name only occasionally.

Is this my problem only or does everyone else have it working this way as well?

I have similar behaviour with a plug used via HueBridge.

I could not identify the reason yet.
I can’t see if the plug is switched in real (it’s only for hot water pump) or if it’s only a timeline entry without switching (state reshresh from Hue Bridge).

Based on this example I would assume…

  • plug is switched off by flow
  • hue reports the old state (on)
  • hue reports the new state (off)
    So it could be a delayed state report from the hub.

For me it happens when I set a dim level from a flow, which internally turns the device on. But the cases above seem different.

1 Like

I think I have the same issue.
In my case a timer app switches a smart plug on and one hour later off.

3 times a day this routine worked and kept the swimming pool clean. I have a pool filter attached.

But suddenly HUE steps in and screws up the procedure :face_with_head_bandage:. When this happens the pump keeps pumping and I have to manually shut it off when I notice it :face_with_head_bandage:.


Hope your all doing on!

I have a similar question to what you pointed out but more specifically the white dots on the time
line what does that represent?

So you can see my lights after they turned off by a flow then randomly turned on and i cant see why (no one else was home so it wasnt a manual switch etc )

I see that white done on your screen shots as well have any of you worked out what it is?

Cheers !

Hi Matt,
Didn’t notice the dot icon yet.

I searched and found a device with “the dot”. It is mostly switched by a sensor.
The room is called “Bijkeuken”
The flow:


The hallway has exactly the same setup, Aqara PIR and Tuya cloud light unit.
Except for it switches the light ON, instead of “dim to 20%” for “Bijkeuken”.
This room is called “Hal”


So, I changed the “Bijkeuken” flow to switch the light ON, instead of “dim light to 12%”
Now it shows the flowname instead of the dot:

Action card “Switch a light ON” shows the flow name;
Action card “Dim a light to X%” shows the dot.
A bug?

Using a “switch the light ON” action card and then a “dim light to X%” delayed by 1s also shows the flowname in the timeline


Well this was amazing!

Thanks so much for all the detailed help!!

I will test with my setup and see now if i can diagnose what was going in with my device :slight_smile:

1 Like