NEO Coolcam Power Plug negative value

Does anyone have the problem when use neo coolcam power plug?it show negative value -21474833.23KWh. and how to fix it?Thank you

use the search button

thanks for your reply. can you tell me more details. we’re the seller from NEO Coolcam.we’re here to find a solution for our customers.thanks

It’s an issue with the new version power plug with device ID: 512 as documented in this post

probably the issue is with the firmware from Neo as documented here on the settings that we can change to at least get it somewhat working with homey. But the value still shows negative which

Not sure if you as a seller can ask Neo Coolcam engineers to look into it with @MarcoRuiter who developed the app for Homey

Yes same issue here :pray: all of my cool cam
plugs have this :frowning: so they are not usable

Same here. No Coolcam products for me any more.

But this is just for the V2 aye?

Yes, all users have this on the V2 version of the plug . Its a firmware bug also confirmed a couple of months ago by Neo Coolcam thru the chat on their site.

Domoticz and HomeAssistant users also confirmed this.
The bug is only in the EU plugs - also confirmed and tested by multiple users on multiple controllers.

Direct connection thru a AEOTEC Zwave stick console communication log also shows the plug reporting the -21xxxxxxx values in its com.

For the record the V1 plugs dont have this problem


I think you better chase the official Neo Coolcam manufacturer who’s plugs you are selling. They should be able to solve this because it’s in their firmware.
I had contact with the official Coolcam store on Ali, but they didn’t come up with any solution.

He is from coolcam :wink:

you can find the ‘app for homey supporting coolcam’ here :

Afaik he is from the Coolcam Store on Ali, and that is not the same as the manufacturer i think.

Is this issue solved now ?? @Coolcam-Harrison ?


I had this issue with another brand of smart plugs. I found that (in my case) it was due to a crappy plugin adapter. (it was an IKEA adapter for a small light platform for a glass statuette)
The adapter even was warm when the light was switched off. So it was poorly created.

I currently have the same adapter between my washer (to get a push message when it’s done, and now it works fine), so if it’s the same issue, it may be caused by the type of equipment your trying to switch. Try something that uses more power?

Then you can rule out Homey and move to the vendor.

the issue is verified on different platforms, so it is a NEO problem to solve :wink:

In case Neo has a firmware update, will this be installed through our Homey app?
Quite annoying those negative values

Yep but do anybody know what about those ones I may buy today? Still buggy or updated firmware?

Still waiting for 4 new ones. Once i have them i will inform you.

I just bought (around november 11th) four of these plugs on ali and i have them running for 4 days. They still have the same issues.
They also have a crappy range, where the version 1 has a range around 5 meter, the version 2 has no more than 3 meters.
The guy from the official coolcamstore on ali told me that homey was not fully compatible with version 2.