Neo coolcam powerplug

Now after a day of use I also have the large negative power meter value problem. For the way I use it this should not be a problem. Do we have any info if this can be fixed with the app update or is it a manufacturing problem after all?

It was a bug in a series of plugs. The guy from China claims someone was able to reset it via an open source z-wave platform, but afaik this isn’t possible via Homey, not even by sending a raw code manually to it.

Still issues with the new Neo PowerPlug that has the Product ID 512 and is marked as secure?
Im not sure this problem is related to the thread at all, but mine doesnt report anything else than voltage.

I have several plugs, all non-secure and never had issues. This secure one is being an ass too me :stuck_out_tongue:

Sidenote: I went into the advanced settings just now and changed:
Meter report intervall: 60 sec
Power change (%): 5%

Anything else is default.

Works now, but its locked to report each 5 minutes. No matter the value change of the plug. The old one i could set to 60 seconds in adv settings.
Also did that to V2 plug but still reports at 5 min.

I just installed the power plug. I can control it, changed reporting time to 60 sec but don’t get any measurements. I want to use it for my evaporator. When it is out of water is shuts automatically off. I wanted to use the plug to get a message if it shut of so I can refill in time.


What am I doing wrong?


Ive given up on the Coolcam V2 plugs. The secure one. Received 3 of them the last weeks now and all of them goes bananas. I have a few of the old once and they work perfect.
Talked with the Coolcam store and they say its not the plug. They all either end up giving negative Power meter or just stop reporting. Might work for an hour or less.

But i have noticed that at low consistent load it seems to work. As soon as you dump som load (washermachine), or if the load starts to vary a lot it bugs.

Also noticed as if i let the settings stay default it works longer, as soon as i change something in the settings it just stops right away.

So far it looks like i have to find other alternativs. Either Inner plugs or go for Fibaro. But they are so pricey compare to coolcam.

@MarcoRuiter : Not sure if you ever managed to get a conclusion?

Now I have these readings.

Neo confirmed it was a firmware issue and the home assistant users also did a thorough deep dive into it and also came to the same conclusion

When you look at the raw zwave data on the developers pages of you’re homey you will also see the raw wrong data about the usage come in straight from the plug . Aka the plug it’s software is failure

Ahh… I experienced the same with the newest plug. Anyone has an idea or the app software can work around this issue? Or just wait before a newer version of the plug will be there?
Or is there a possibility of a firmware upgrade?

I just read the smartthings forum and they say the same. I’m dealing with neo now. Hopefully they send me new plugs of V2 without issues. I asked if they still have V1 in storage because its only 3 weeks since I got one that was V1

Edit: Neo said i could just return the plugs if they dont work.

Maybe its not even relevant, but this is what the smartthings forum found out:

The old model supports values 1-100% the new model supports 0.01A - 16A (1-1600) and 50% of 1600 is 800.
It’s just the pending change calculation that has an issue, but I’ll post another test version shortly that will hopefully solve the problem.
Update: I finally found the problem so I’ll have the new version posted to GitHub shortly.

1 Like

just some info here. got 4 powerplugs in and all four were faulty. for the ones i could connect i saw they had different firmwares (2.21 , 2.23 and 2.80)
i am a bit wondering if that would make them working or not since the led worked on two of them but no power and also not able to add them properly.

two did not even passthrough power and one worked until a bit power was drawn and then it short circuit and kept doing this.

i have a neocoolcam that has the same manufacturing id, product type id and product id which works fine so i wouldn’t thought i would get 4 faulty ones.
Now maybe thinking of another brand to use so if someone knows another brand that mostly works fine besided the Fibaro devices.

I would like to know as well, how to find out if I have a V1 or V2 model. How can I check this. I bought this one: NAS-WR01ZE

I added a new NEO powerplug and selected it as v2 as the new device because I didn’t know if it was a v1 or v2.

After it included, the name given by Homey was something like “NEO powerplug v1”…

So, that was easy in my case!

OK I could try that as well. And once you knew it was v1, did you had to delete the device and add it again as a NEO Coolcam powerplug v1? Or will it just work when adding the device as v2?

I believe it doesnt matter what you select when adding it. Homey automaticly select the right one.

1 Like

Yes, it will work fine!

1 Like

Go to the devices section on the Developer page and take a look at the plug’s values. You could also do that by opening the devices advanced settings via the mobile app.

V1 has:

V2 has:

1 Like

Hello, i am using several Neo Coolcam powerplugs for mesh purposes and power monitoring.
Since yesterday the powerplug on my tumble dryer is giving occasional power peaks of around 350 kW
anyone have an idea what might cause this?

Some seem to have this . The cause hasn’t been really clear but it’s ofc a firmware of the device issue but also seems to be caused by something on the electrical net .
The next version of the app should drop any reports that are out of bound . Hope it will be available in the next weeks

Have that issue too. As the spike value was always tthe same, I adapted flows accordingly.

So in the AND section I placed a logic card “value is not exactly…”