Neo coolcam powerplug

These flow works , only it gives the change of watt once a minute, not directly.
So it reports the change of watt, or am i wrong ?

Yes, of course it does, it is a value that is reported. But the trigger is the report interval, not the amount changed. At least, not for the watts.

I realize my statement can be confusing, so i adjusted it to make it more clear.

I will post an overview of the parameters of both versions later tonight.

When i try it with a lamp in the powerplug, with more watt instead of the tv reciever it for sure works, with the same flow.
So the change of watt can used as a trigger.

Obviously. Are you sure that is instantly and not because of the interval reporting?
Anyway, you can’t change the setting, alas. At least, not according to the Neo Coolcam manuals.

At the moment, only the settings of a V1 Coolcam plug can be changed via the advanced settings in the mobile Homey app. For a new V2 plug this won’t work because the parameter numbering is incorrect.

(I understood the app developer, Marco Ruiter, is currently working on this and it will be possible to change settings for all plugs again in a coming update of the Coolcam app.)

For now, if you want to change a setting of the new V2 plug, you will have to do this manually. You need the values as listed in the table blow. There are 2 ways to do this:

  1. Via the option “Raw configuration parameters” in the advanced device settings in the mobile Homey app. Insert the values In the “Value” field in the format ‘parameter id, size, value’, for instance “3,1,1”. Then press back (left upper corner) and then save the settings (right upper corner).
    The parameter setting should have changed now.

  2. Via the developer page, Z-wave section ( Scroll down to the Tools section. There is a field in front of the “Send RAW data” button where you can insert the values.
    In this case you also need the Z-wave id of the device you want to change. This id can be found in the node overview on top of the developer Z-wave page. It is the colored number before the device name.
    Fill in the values in the format ‘device id, parameter id, size, value’, for instance “44,3,1,1” and press the “Send Raw Data” button.

Table 1: parameters and values:

Param ID V1 Param ID V2 Description Size Values Units Default value Remark
1 6 Plug meter reporting on/off 1 0 (disable) or 1 (enable) - 1 Enable or disable the reporting function
2 7 Plug meter reporting interval V1: 2 1–65535 Seconds 300 Time in seconds between every report to the host
V2: 2 30–32767 Seconds 300
3 8 Maximum current output 1 1–16 Amp 16 Maximum current the plug will supply. V1 will stay on and turn yellow, V2 will cut-off
4 10 Maximum current alarm threshold 1 1–15 Amp 15 Value must be less that the maximum output value! LED will turn yellow and alarm sent
5 3 Led Display Enable 1 0 (disable) or 1 (enable) - Enable or disable the LED indicator
6 9 Plug meter report on current change V1: 1 1–100 % 5 Percentage of current change that will trigger report
V2: 2 1–1600 Amp 50 Amount of current change that will trigger report where 1 = 0.01A, 1600 = 16A
7 1 Remember Relay ON/OFF status 1 0 (No) or 1 (Yes) - 1 Enable or disable the previous state after power loss
8 4 Configure Plug Time switch Function 1 0 (disable) or 1 (enable) - 0 Enable or disable the switching timer function
9 5 Configure Time switch Period 2 0–32767 Seconds 120 Specify the switching timer value
10 2 Button On/Off Enable 1 0 (disable) or 1 (enable) - 1 Enable or disable the manual switch button
1 Like

Thanks you , for all these info. Tomorrow i shall experiment a little more an let you know !
Otherwise i shall must wait for the update !

Is tried everthing today but what i want will not work. Wil it work after the update of the app or should i look for a plug V1 ? How can i see the different between V1 and V2 ?
Thanks for helping me guys !

I have tried this now both via the app and the developer page, but I cannot get the led indicator, or the manual button usage to change (I tried those because I can check if the settings actually changed) I also tried the codes for the V1, but still nothing. Do you have any tips, because im not sure what to do now. Thank you in advance.

1 Like

Sorry, missed the post…
I realized something last weeken when i was playing around with the new plugs.

The manual for a V1 says param 6 is adjustable for reporting on the % of power change. And in the settings page, power shows as W.
In the V2 manual it clearly states that param 9 is a setting that can be adjusted for reporting on the amount of current change, thus A.

So now i am a bit confused in what the setting in V1 is really for W or for A. Going to test some this week, let u know.

When did you buy the plug? Is it V1 or V2?

1 Like

Thanks for your quick reply, It is a V2 I believe since it says its secured. However I’ve just managed via the app, I hadn’t seen that the device ID is no longer required doing it via the app, so I used a digit too much, and it worked! Thank you again for your extensive guise and quick response!

1 Like

You’re welcome and thanks!

Now after a day of use I also have the large negative power meter value problem. For the way I use it this should not be a problem. Do we have any info if this can be fixed with the app update or is it a manufacturing problem after all?

It was a bug in a series of plugs. The guy from China claims someone was able to reset it via an open source z-wave platform, but afaik this isn’t possible via Homey, not even by sending a raw code manually to it.

Still issues with the new Neo PowerPlug that has the Product ID 512 and is marked as secure?
Im not sure this problem is related to the thread at all, but mine doesnt report anything else than voltage.

I have several plugs, all non-secure and never had issues. This secure one is being an ass too me :stuck_out_tongue:

Sidenote: I went into the advanced settings just now and changed:
Meter report intervall: 60 sec
Power change (%): 5%

Anything else is default.

Works now, but its locked to report each 5 minutes. No matter the value change of the plug. The old one i could set to 60 seconds in adv settings.
Also did that to V2 plug but still reports at 5 min.

I just installed the power plug. I can control it, changed reporting time to 60 sec but don’t get any measurements. I want to use it for my evaporator. When it is out of water is shuts automatically off. I wanted to use the plug to get a message if it shut of so I can refill in time.


What am I doing wrong?


Ive given up on the Coolcam V2 plugs. The secure one. Received 3 of them the last weeks now and all of them goes bananas. I have a few of the old once and they work perfect.
Talked with the Coolcam store and they say its not the plug. They all either end up giving negative Power meter or just stop reporting. Might work for an hour or less.

But i have noticed that at low consistent load it seems to work. As soon as you dump som load (washermachine), or if the load starts to vary a lot it bugs.

Also noticed as if i let the settings stay default it works longer, as soon as i change something in the settings it just stops right away.

So far it looks like i have to find other alternativs. Either Inner plugs or go for Fibaro. But they are so pricey compare to coolcam.

@MarcoRuiter : Not sure if you ever managed to get a conclusion?

Now I have these readings.

Neo confirmed it was a firmware issue and the home assistant users also did a thorough deep dive into it and also came to the same conclusion

When you look at the raw zwave data on the developers pages of you’re homey you will also see the raw wrong data about the usage come in straight from the plug . Aka the plug it’s software is failure