Multiple Z-Wave device commands fails


I am new to Homey Pro, previously my home was managed by Jeedom with Aeotec Z-Stick running on Raspberry Pi. I have many Z-Wave devices, including four Fibaro Roller Shutter v3 and two Fibaro Dimmer v2.

I have a flow to open simultaneously all the four roller shutters. Most of the time only 3 shutter open and one remains closed, I have to restart the flow a second time to force the last shutter to open.

It seems that sending simultaneous Z-Wave commands with Homey is badly supported (see other threads in the forum). A workaround is to insert small delays of 1 second in the flow… seems quick and dirty, and for lighting this is a poor solution, once lights from the same room starts with a delay. Another quick fix is to use the application, however this is acceptable when opening all the shutters in the morning, but not usable in the evening when the closing shutter when kids are going to bed at different times.

Moreover, the workarounds proposed here above does not work neither with HomeKit nor Alexa home automation. When I say “Hey Siri, please open all the roller shutters” in the morning Homey does not insert small delays automatically between commands and some shutter remains closed.

I already reported this as a bug, but Homey team does not want to leave it open as it exists workarounds… this is quite disappointing for my first month with Homey.

I hope this will be solved as soon as possible!

A common workaround is to enable unsecure pairing, which solves a lot of problems for a lot of users: Add Z-Wave device non-secure?

Hi Robert, thank, but for me security is not an option… I will still wait until Homey has fixed this issue.

I can also add that was working fine with the Aeotec Z-Wave stick (with secure pairing)
I’m convinced this is a bug in Homey software… maybe an easy way yo solve this is to add a millisecond delay in the send queue?

You should tell Athom.

This is a community forum and the community cannot work on improving the Z-Wave stack. However, as you have already noticed, Athom doesn’t seem to be inclined to fix this problem (and it has existed for a long time now) because, basically, they don’t acknowledge it as being a problem.

So you can wait until Athom fixes the issue (which may be never) or be pragmatic and read up on what “secure mode” in terms of Z-Wave actually means, and that it doesn’t mean that your network is not secure (from a hacking standpoint, if that’s what you’re worried about) if you don’t use it.

Thanks Robert for your constructive contribution to this thread!
I’ll will do the test, and give my feedback here in any case.