Flows that sometimes do not activate all lights

Hi My Homey Pro ver. 4.2.0 does not turn on certain lights sometimes, but if I run the same Rolls again manually, it works.
I have tried to put the ignition of the same lamp several times in the same Rolls but it does not help. Have also connected signal amplifiers to certain lamps but it does not help either.
The lamps have been installed via Zoon and as individual lamps.

Is there any setting I can make so that Homey default sends out more than one signal to resp. remote switch?
Telldus Controller has this function.

Flows sending commands to multiple devices may not work properly. This is an internal issue with Homey.

I believe that for Z-Wave devices it’s possible to improve this behaviour by adding the devices unsecured, but this isn’t always possible (and also requires downloading and modifying app source code).

Otherwise, you need to add delays in between the action cards:

  • turn on lamp A
  • turn on lamp B after 1 second
  • turn on lamp C after 2 seconds
  • turn on lamp D after 3 seconds

Thanks robertklep
Sad that it does not work with Zons would have been smooth. Have tried to redo my flows in this way but they still did not behave as I had expected. So I removed flows completely and created new ones and then followed your tips. They have now been a few days and it works so far. Many thanks to the council robertklep :slight_smile:
Is there any way to see what the code behind the graphical interface looks like?
/ Göran

This is by far the worst issue with Homey, not being able to trust that a signal is sent or not. And also, a 1 second delay between each command, what is this, the stone age? Sending multiple signals at once should not be a issue. The hardware is more than capable of doing that. I haven’t heard anyone using similar solutions (Smart Things, HA etc) having even remotely the same issues as with Homey concerning these types of “bugs”.


I have Fibaro dimmers and hue lights all over the house and outside. I use dim to 0 and 2 sec delay between: 0,2,4,6,8 sec etc. Works seamless and looks cool when you create a certain order. When I turn all lights off it starts from way back in the garden and works it’s way to the front of the house.

Regarding this issue that I have observed myself as well.

Is it possible to handle “errors” in the device through the flows or at least to see in the logs if a command has failed?

I don’t think that commands are failing per se, I think there’s something internal to Homey that is causing commands to be “missed”. But as far as Homey is concerned, everything is okay (if this is what’s happening, it’s clearly a bug, but one that has existed for so long now that I don’t think it will be solved any time soon).

1 Like