Light flows only works sometimes

i have a few simple flows that control my lights, but they have a life of their own. Some times they work - some times they dont. And i cant see why.
The flows i like this. if there is motion and the time i between 23-06 then dim lights to 20% else dim to 100% and set at timer to 360 sec - after this a different flow turns off the lights when the timer hits 0.

I have been using Hue sensors (3 units) and hue bulps. On the sensor i can see the led indicating motion lights up but the lights does not turn on - other times it does.
I have added a card that animates the led ring on Homey to see i the flow is running - it is not always the case.
So the problem must be with the sensors it seems, so i have gotten new Xiaomi Aqara sensors and replaced my Hue sensors - sadly the result is the same. The new sensors register motion but the flow is not activated.
As of now the hue sensors i back together with the Xiaomi to see if a greater number of sensors can force Homey to react - it does not seem to be the case…

I use two flows to control the lights in this part of my house because of the layout - one sensor can not cover i all. So sensor 1 activates flow 1, and sensor 2 activates flow 2 - the flows are the same.

Distance to the sensors i between 15 cm to 3 meters so range cant be an issue

can anyone tell med what is going on before i go crazy ?

Could you share the flow and post it here?

It seems to be OK. Try to look in insights how are the Homey resources used. Another option is to put some delays on each of the bulb.

but how will a delay help when Homey does not runs the flow even when motion is shown on “properties” tab on the sensors.

I dont quite know what to look for in insights, but Homey only uses 511 mb of memory and almost no power

It should work as you made it, but maybe there is a problem with the card that you use and the way you use it:

Can you try to change it into “The time is between 06:00 and 22:40”, should do the same but there is no “day-crossing”. Think it’s worth trying.

Try making this flows and see what happens.

I have tried with "The time is between 06:00 and 22:40 " and even with leaving it out completely.
It still does not work everytime