MQTT: it seems running, but there are issues in Home Assistant

I wanted to make a dashboard in Home Assistant, so I followed this tutorial. It all seems fine. I selected all devices and there are 57 items in Home Assistant. But:

  • there are some devices not pushed to home assistant.
  • i figured I could hookup the Hue bridge to Home Assistant directly, so I disabled Hue items. But the list doesn’t look up to date on Home Assistant.
  • when tapping on a sensor in Home Assistant I see: this entity is not available at the moment…

It all seems a bit vague. I have to admit I’m a noob with MQTT. I was amazed that they were exposed in Home Assistant, but now I need them to be there without ‘errors’ and I’d like them to interact with my floorplan :slight_smile:

Hi Renzo, have you found a solution for your problems? I’m trying to setup a Dashboard in HA as well. 90% Is working fine and it’s going to look awesome, but some of my (KlikAanKlikUit) switches aren’t recognized. In the MQTT Hub app on homey I’ve selected every device.

It does work now. I’ve deleted all apps from Homey and HA. And I did it all again. Strangely enough I’ve got the right things and it works now.
I do have every so hour that my broker is offline and online within the same minute. Not sure if that is my NAS, the broker or Homey which still has a lot of connection issues.

You have selected them in the MQTT hub on Homey?
Can you find them being published with a MQTT app (like MQTT Explorer)?
They aren’t found anywhere in the list of devices entities on HA?

I do see them in MQTT Explorer, under ‘homie’ , one of them looks like this;

Under homeassistant it looks likes this:

But I try to add it to my dashboard with;

But this doesn’t do anything. Also tried other variations with/without spaces/capitals, but no luck.
The light is connected to a dimmable socket-switch from KlikAanKlikUit, type ACD-300.

Hmm, I don’t have any lights. Only sensors because my Hue is still connected to its Bridge.

But if you look inside HA, go to settings, integrations, mqtt and see what entities you have. If you do not see a list of devices and their entities I guess HA isn’t configured the right way.
My configuration.yaml looks like this:

port: 1883
discovery: true
client_id: home-assistant
discovery_prefix: homeassistant
topic: ‘hass/status’
payload: ‘online’
topic: ‘hass/status’
payload: ‘offline’

I’ve 44 devices and 156 entity’s according to MQTT, but at least 2 entity’s aren’t listed. My configuration.yaml looks like this:

username: [username]
password: [pass]
discovery: true
discovery_prefix: homeassistant

I’ll try your configuration;

EDIT: no difference :frowning:

I’m sorry, I think my knowledge isn’t sufficient for this. Have you tried the HA forum?

I’ll try over there. Thanks for your support so far!