MQTT Home Assistant - Devices shown, but can't control them


I’ve used home assistant in combination with homey in the past (HP2016) with no issues. I recently set it up for HP2023. I’m using the home assistant broker and the MQTT client and hub apps are running on my HP 2023. The devices are showing up in Home Assistant, and state changes are reflected accordingly, but I can’t control device from HA. Any suggestions on how to fix this.

With my Pro 2019 I had ‘frozen’ Homey devices on HA very often.
Someone in the MQTT Hub app topic, pointed me to these settings, and the problems are gone.
It might help on a Pro 2023 as well!
If I were you I would not change the topic field you have right now

Thanks @Peter_Kawa! This solved it for me as well.

1 Like

Nice to hear!

Hi @Peter_Kawa , did you change anything else, as the settings shown in the screenshot? I got prettymuch the same problem (with HP2023) and getting crazy with the HA-connection. Devices are shown correctly (inlc. state) but I can’t control these inside HA. Any further ideas?
thank you very much in advance

No, that’s it afaik.
Probably things, and/or the Mqtt Hub app, work slightly different on the Pro 23.
But I have no info of issues with other Pro 23 users with HA integrated → which does not mean there are none

Hi Rolf - did you ever get this resolved? I have the same situation you described. I can see all devices from HP2023 inside HA but cannot control them there. Thanks

Tried the custom settings, or not?

Thanks Peter

I had tried the custom settings.

The good news is it’s working now after I changed them a little. I wasn’t really sure what I was doing but I had success with changing topic from




And I had a couple of other similar changes in the Command section.

Anyway as I said I’m not sure if those changes were correct but they seemed to work for me

Thanks again for your help and your detailed guide.

1 Like

Hi all,

I had a client facing similar issues.
After checking all the settings, I could still not control some devices from HA.
Eventually, I figured out that some devices in Homey were having the same name, and were conflicting each other.

So please check for unique device names as well while facing issues!

1 Like