MQTT Hub/Gateway

Works like a charm after latest update. Many thanks!

1 Like

Version 2.1.3 (app beta channel)

  • Updated Homey api to version 2.1.172
  • Home Assistant Discovery: on_command_type for lights set to ‘last’

I upgraded Homey to 2.0.5rc4 a couple of hours ago.
Just now I tried using Google to turn on a light and nothing happened.
After I stopped Hub and Client and restarted them (first Client, then Hub) it worked again.
Is it possible there is still a problem with the order they are started?

@Fire69 did you also try it the other way around? First hub and thereafter the client? If you did, did you encounter problems? Do you see errors in the log?

Be aware the hub needs to send a lot of messages in the startup phase (broadcast), so it can be less responsive to external messages at first. I’m planning to make this process a little more visible (e.g. a progress bar or something).

No, didn’t try it the other way. I think you said in the gbridge-topic that client=>hub was the correct order so did it that way :slight_smile:
If you want I’ll try it tomorrow.

Everything was started for some hours already after the firmware-update so I don’t think that was the problem.
After restarting both apps, everything worked correctly right away.

Version 2.1.5

  • Option to enable/disable all devices
  • Performance & stability improvements

Version 2.1.4

  • Display broadcast progress

Would love to see how you did this

1 Like

@Casper181 It’s HABPanel. Configured via a Homie mqtt device.

Does anyone else have problems with Homey firmware 2.0.5? See:

I spent all afternoon trying to figure what’s wrong… So I wiped my settings and started over many times…

I’m still on 2.0.4 myself, so I can’t reproduce the problem…

I’m on 2.1.5 and 2.0.5, no problems here.

What do you want to know @Casper181
Install Openhab on a NAS, install MQTT Broker on a NAS or Homey, Install the MQTT Client on Homey and install the MQTT Hub on Homey.
Setup all the applications. Push all the devices to OPenhab and start to install the widgets.
I have made several widgets. See

Current dashboard

I didn’t until i made a change to my set up

No problem with 2.1.5 in combination with 2.0.5

I’m building a HA Dashboard (work in progress…)

Endless possibilities :slight_smile:


Looking good. Is this the frontpage? Are on the top links to other pages?

Yes, and some of the front-page buttons (devices, zones, etc) navigate to the detail pages.

I like different ways of accessing & overviews of my devices (floorplan, tiles, list, categorize per type or zone, etc.)

Any ideas on this

Nope, I’ve very little information, inconsequent reports and I can’t reproduce myself…