Missing zigbee node

Tried the search function but did not find a result, I need some help with the error Missing Zigbee Node on my bridge.

This afternoon at sunset I noticed my lights were not turning on by the normal sunset flow, whole the flow was triggered because I got the notification.

I just turned on the lights by switching the lights itself off and on (tradfri default behavior after power loss is to turn on) without thinking because I was in a hurry.

Tonight I wanted to play around some more and I found out the lights were still not working. Tried using the homey app and voice commands using Google.

The error I get is Missing Zigbee Node for all my lights in the tradfri app, also the aqara app with a doorsensor is not working and a tradfri motion sensor is not triggerd. The netatmo thermostat valves seem to be working correct, so it’s not the full homey bridge which is not working.

Any one has a clue what to do? I did try the magic off/on of the bridge itself.


wifi & zigbee channel tuning, while they can interfere

Zigbee channel can be found & set right below “System information” @ this site:

1 Like

Tried the links on your url, but it’s about building a stable network, however I have limited devices, which are almost all powered and thus part of the mesh if understand correct. I did not find the error on your url, only interviewing as a pending state or so.

Edit: will check the channel for interference, however it all of a simudden broke because until this morning it was working fine…

Edit2: changing zigbee channel seems not supported on the bridge (error which states then when changing in the dev tools site)

Edit3: according to the site, my zigbee channel is 21, my wifi channel is 9, so I guess it’s the worst option. Will investigate if I can change my wifi channel. I am using a tp-link mesh which optimizes itself so regarding the wifi it’s the best apperantly.

Idk if Netatmo joins your zigbee mesh.
You can see the most recent zigbee routes at the developer site.
Not all zigbee devices are compatible, but Ikea and Aqara are.
Probably your Netatmo’s are paired direct to the bridge and don’t use the Ikea/Aqara zigbee mesh.

Could be real if your wifi system isn’t set to a channel, but is on ‘auto’ channel
Or, other wireless radio’s suddenly interfere (neighbors, other devices).

You should be able to change the zigbee channel by selecting the channelnumber itself @ the developer site.
That possibility isn’t visible until you select/touch it.

Will check it out tomorrow, not familiar with the dev tools. Thank for now already.

1 Like

Well, i ended up in just removing the Ikea app and repairing all devices. Did not find an other solution. Luckily i don’t have so much yet.

This reset learned me to make more use of rooms instead of the lights itself. This makes fixing the flows easier or even not nessecary at all (turn on room instead of turn on this and this lights).

Also i tried changing the zigbee channel, but it is really not possible, got the same error as yesterday:
Unfortunately my TP-Link mesh devices won’t let me choose my own channel, its fixed on auto. So channel issues will nog be resolvable easy

Got one question left, is it possible to manually change the routes the zigbee devices make? Because my doorcontact is now hopping 3 times before it reaches the device itself. This while i paired it just a few cm’s from the homey itself. Also because the number of zigbee devices on the homey is limited, i would like to have 1 spot as main and the other 4 (it’s 1 armature with 5 spots) as childs

I will be digging in the forrum to find if i can change the route somehow

That’s just weird.
Is it possible to reset zigbee? (Phone app: …More>Settings>Zigbee).
A reset should make zigbee pick a quiet channel by itself.
Note: You’ll need to pair all zigbee devices again afterwards, and repair al related flows
The issue is, what do you gain if your TP-Link decides to change the Wifi channel some day… It’s weird also you can’t pick a Wifi channel yourself.

It should not matter if it hops x times to reach Homey.

You’ve set it up well, using many router devices. You can pair up to 15 devices directly to Homey, and then an additional 20 to 25 via paired router devices.
You are free to add more, but at some point the network becomes sluggish or unresponsive at times.
And to compare, a Hue or Tuya bridge have a 50 devices limit.
A Deconz Conbee mesh can have up to 200 devices, but can’t be controlled by Homey Bridge, only by the Pro model.

1 Like

512 at the moment.


Thanks for your replies.

Wow, très cool! And is it usable irl? You heard of any user who has 200+ devices? Just curious :upside_down_face: