Meross MSG100

Hi, I have the Meross msg100 but the app only has the 200 will this still work ?

Did you try?

I know this an old conversation, but also am aware that a lot of users own a MSG100 garage opener. (for 1 garage door)
As the MSG200 is for a double garage opener, I think there might be more demand for the MSG100 in the Netherlands than the MSG200.

I just tried to get the msg200 driver to work with an MSG100 and I get the error: 'Cannot read properties of undefined (reading ‘data’)

I am also wondering if this app is still maintained, all the more recent accessories seem unsupported.

1 Like

I am waiting for support for msg100. Unfortunately it doesn’t work with msg200. I hope the developer provides this for us. I transferred it via homeassistant but unfortunately it didn’t work properly.


I never managed to get out work tried with Alexa that way but won’t go over. Same with the mss310 plug seems anything that is native HomeKit is not supported.

Does Homey actually support anything?!
Everything I own is supported by Tuya,
Apple Homekit or Alexa.
But when it comes to Homey nothing is supported or works well.
is the homey pro actually worth it?

From the change log from the meross app the MSG 100 is now supported :tada:, unfortunately I can’t get it to work yet on my Pro 2023, as I get the message: Cannot read properties of undefined (reading ‘data’), when trying to add the device.


Ok, with the latest update of the meross driver I got my msg100 garage opener working.
The cannot read properties of undefined (reading ‘data’) disappeared and the msg100 got recognised when I manually put in my meross login details in Homey 2023.

I have the same issue, same error message.
However i cannot fix. I have multiple time removed installed the app.

May i ask what is the app version for you? Mine is 1.2.1.


I am on 1.2.6 (test version)
on 1.2.3 & 1.2.4 some fixes were implemented for the msg100

Cool! Can you help me how i can use newer version and not just the default? I always just got the 1.2.1 :frowning:

This should be the link to install the 1.2.6 version.
If it still doesn’t work after, let me know.

Thanks for the link! Yep with this I could install the latest experimental with 1.2.6.

However the sad news I have still get the old error if I try to add new device.
Currently I have a mss245 power surge protector
And an MS100 garage door opener. Both of them are in homekit.

I have set always the username password for the app, but I just got this error:

No idea what could be the issue. :frowning:

  • Select the [settings icon] in the top right.
  • Select [App Settings]
  • Fill in your Meross Cloud Settings and [Save changes]
  • Go back to [devices] and try to add the msg100 again.

Now it should work.

Thanks! But It is still the same error again. I filled the cloud settings. I try to restart the app, but the still old error again when I try to add.
Not sure what it want to read from where. Interesting, because in the meross app they are there. Even in homekit I can see and I can control them.

Thanks for the support by the way. Maybe once it will work, or I would understand the error real meaning.

I Have this device MSG100, and it sucks with MESH routers, keeps disconnecting all the time, I ended up buying another smart garage opener from Loratap with a wireless sensor. If someone wants to have it, pass by Zwijndrecht.

How you integrate loratap devices with homey?
Tuya app works with the zigbee version?

It doesn’t, yet. I had bought it before getting the homey pro, was working fine with home assistant. I have also donated some money to the developer to get 3 devices supported and unfortunately, his currently MIA. I hope his ok and nothing serious had happen to him.

If you have HA running you can try installing Home Assistant app on homey and expose the device on homey.

Unfortunately I no longer have HA. Maybe I get the HA green and sell homey pro if things are not getting better from Athom perspective. Let’s see, I really hope not maintaining two separate smart solutions.