Meross Smart Wi-Fi Outdoor Plug

When I try to connect Meross Smart Wi-Fi Outdoor Plug MSS620 to Homey Pro (early 2023) I get the message: “Cannot read properties of undefined (reading ‘data’)”, whatever I do. I have installed the Homey Meross app 1.2.1 and read that MSS620 would work with Homey Pro(2023) but there are several different plugs with the same type number. I succeeded to connect the device to the Meross App but not to Homey Pro with Meross app. Do I miss any configuration setup or what?

Hi @Nisse_Hellgren ,
did you already ask the developer? The description of the App (Meross App for Homey | Homey) says you find him under the email address (
Good luck

Hi, I have not asked the developer yet. I did send a request to the seller who stated that the device will talk to Homey. I will send my expreience to the developer as well. Thanks and hopefully a Happy New Year!

Maybe you have to install the 1.2.6 version?
That is a testversion Meross | Homey

I tried to install the test version 1.2.6 but that was not what I did wrong. I solved my problem when I went through the installation and connection steps correctly - i.e. installing Meross app, creating an account, log in, connect the device (as I did from the start), installing Homey Meross app, log in to the Meross account (which I did not do in my failure attempt) and then successfully connect the Meross device to Homey (almost like connecting Philips Hue devices). But I did not understand the error message correct - to me it was somewhat cryptic - though indeed correct as it indicated configuration data as incorrect because it was situated in the Meross app data - so login from Homey Meross app to Meross app data was then reading the configuration data.

1 Like

I was getting that error too until I realised that I needed to put my Meross account username and password into the Meross app settings first. Have you tried that?

thank you :slight_smile:

It looks like Meross has subsequently broken their API and the app hasn’t been updated. Lots of folk are reporting that their Meross devices are now broken.

My Meross Homey App crasched and when I reinstalled the App I got “New Devices Found” followed by “Request failed with status code 404”. To me this simply means that the requested device (resource) can not be found even if “New Devices Found” and that the Meross App works just fine. Is this a consequence of the latest Homey Pro update on WiFi connection?

I have the same problem with the error code 404 when I try to implement the mss620 smart outdoor plugg.

I have a mss630 3 outlet outdoor plug and it connects to Home through the Homepod mini but not to Homey/Pro 2023. The mss630 is not listed as a device in the Community Meross app. I’ve sent a message to the app developer to consider adding this device. Any other ideas?