Meross App crashes

Hello everyone,

The Meross app stopped working a few days ago. It has crashed. Rebooting does not help.

Therefore I have uninstalled the Meross App from Homey and reinstalled it. Now there is no longer an entry that it has crashed, but it is not possible to add devices.

Unfortunately, the developer is not responding.
Does anyone have the same problem?

1 Like

Have you tried the latest experimental version? (The link is in the forums under a post from me).

Thank you very much for your answer. Do you mean this?

It is a great pity that there is no solution. Since the developer of the app is not responding, we unfortunately have to assume that Meross devices will no longer work in Homey. And as long as there is no new app, it will probably stay that way in the future.
That is a great pity. So I will (once again) have to part with all devices from one manufacturer and look for alternatives. :grimacing:

I can’t use it here either, it just crashes and the developer doesn’t respond emails

I have since found out that meross has changed the API. Therefore, the Homey meross app is no longer compatible. The developer has to adapt the app to the new API, if that is possible at all.

However, since the developer developed the app as a hobby in his spare time and is now no longer responding, we unfortunately have to accept that meross devices will no longer work in Homey.

I have therefore parted with all meross devices. I now use devices from Shelly. I don’t expect Shelly to have such a problem in the future. Firstly, the developer of the Homely Shelly app is Shelly himself, and secondly, the Shelly devices are completely self-sufficient. Each device has its own integrated web server and works without a cloud connection and without an additional app.

Today I had to restart the Homey Pro. Since then I am not able to restart the meross app anymore, it immediately crashes when trying to start it. Before it was working flawlessly.

Same here. RIP :frowning:

Nope, it’s just still the same dev named Phuturist with a company name (Allterco Robotics), so he was able to publish the Shelly app to Homey cloud as well.

Hopefully someone will be able to recreate this plugin or we should contact Meross to ask for it maybe :slight_smile: I still like the Garage door opener a lot.

Same here. So sad.
Are there any alternative garage openers on the market?! Or as easy to install?!
What product do I need from shelly or fibaro to do the same thing as the Meross garage opener?

Thank you.
I just also want to use my sensor cable too (from meross) and if i do change, i would like to use zwave (or zigbee)! :grinning:

1 hour ago I updated Homey to 10.0.5 and Meross stopped working :frowning: Maybe it is something related with Homey upgrade. Before update on 10.0.4 I restarted homey many times and it was working normally.

Mine has failed too, a restart fails, just says crashed still, a reinstall seems to fix the crash i.e. the App runs but it now won’t find any of the devices that were installed - seems to have happened in last few days as it was pretty stable since test version released a while back.

I’ve dropped a note to Bence who sorted the test version previosuly but last time he took a while to respond so don’t expect a quick fix. A bit annoying as got to go and fix all the flows now.

Mine has crashed now that I have restarted Homey.
If you want to still use Meross for the time being, then use the “Smartthings 2” app by Ady Rockall and link Meross to Smartthings. Some limitations but works.

Do you care to elaborate more, if i can get mye MSG200 to work through smartthings 2 that would be awesome.

Here’s the SmartThings 2 app from Adrian located:

It’s in the fairly re-newed Homey Community Space store. Independent from Athom.

Thank you for the relpy :slight_smile:

Any chance any of you could make a quick guide on how to pair meross (in my case MSG200 garage opener) to the smartthings2 app?

I have the app and HCS installed :slight_smile:

Edit: I did what every sain human does and googled it. All good and got my garage flows up and running again!

1 Like

Can you share the pair-howto with the lazy Meross users? :crazy_face::blush: