LightwaveRF wireless switches no longer working after update!, any ideas?

Hi All, My Homey updated last couple of days, however my Lighwaverf LW205 wireless switches are no longer working, I have powered off homey for 10 minutes (cable out) and still cannot re-add them.
I add through devices but when I press the wireless switch, homey is not responding. Does anyone else have this problem?

Any ideas?


I have the same problem but not sure when it started.
I can see the signal being received in the tools - Record 433MHz.

You should contact directly.

I reported it on the App github a few days ago and included the recoding, etc as I thought it was an App issue.

Thanks all for the reply, I’ve emailed support.

1 Like

Having the same issue, all my mood switches have stopped working, which isn’t ideal considering they’ve replaced half of the light switches in my house and run through flows on homey!

My LightwaveRF doorbell flows stopped working the other day too. Couldn’t get it responding at all so tried to add the doorbell to homey again but now I get no response from the doorbell to homey when I press the button. I’ll try some of my other switches but wondering if homey is not precessing signal for some reason.

3 emails to athom and I’ve heard nothing. Homey will be getting sold if this isn’t sorted or I at least get a reply soon.

1 Like
This is an app from a non-Athom developer, he should be able to update it…

Athom’s app in beta:

Only supports 4 remotes at the moment so may not be useful yet.

Hi all, hoping you’re all OK. My Gen1 LW wired switches have all gone offline tonight in homey app, with a spinning circle on all light switches in devices, when I go into the lightwaverf app, (0.09) and try to start it, I get an an error about API not compatible! I’m not really sure what to do. Any seeing similar? Perhaps Athom has updated something, again not sure!

Have you tried to restart Homey?

Hi Adrian, thanks for coming back to me, I did restart from the app last night, and this did not fix it. I then thought perhaps reinstall might help, however since uninstalling I now cannot find the app and version that i had installed that supports the light switches and more. I cann only see the version that only supports the remotes! Any ideas?

Ooh, I think the version you had was the one before Athom took over the app. I’m not sure if that is available on GitHub.

It’s here:

But you will need to load it via the CLI.

Edit 2
I have just noticed that it’s SDK 1 so it won’t load on Homey v5 firmware.
Did you update your Homey?

If you can stretch to getting a link plus then you can add gen 1 dimmers to that and use my LightWave Smart app.

yeah looks like it, I just tried installing again via CLI and you’re right…am seeing: × An unknown error has occurred [incompatible_app_sdk_version] in the cmd window!

is there anything else I can do to get this running?

Convert it to SDK2 or 3 but I’m not sure what is involved to do that.

Hi Adrian, thanks very much for your help, I have the new link box setup with the smart app, all working again. Perfect thank you. A really nice unexpected result was the new link box being backward compatible with gen 1 :+1::+1:shame I can’t get the gen1 wireless dimmers to work though still.

1 Like

So do you mean they are not working with the link plus and my app or that they stopped working with the LightWaveRF app?