Debugging non-working 433MHz remote switches

I have two types of remote switches. They are both the common type that comes with a simple remote, but two different brands. They are all scattered across our house. If I use them the ‘normal’ way (i.e. with their remote) they work perfectly fine. So no issues with the switches themselves.

I have added them to Homey using the official plug-ins for respective type, although admittedly one is for another brand. They have worked very well for 6 months, but recently they have stopped co-operating.
If I just toggle the device (no flow) it does not always react. Sometimes it will, sometimes it won’t. It still works perfectly fine with one device located on the opposite side of a wall, but not with on sitting 1.5m from the Homey. I’ve tried various distances, but it does not seem to work.

I have checked the activity for the devices and they should indeed be switched on/off as I command. But nothing happens. I have 1.2GB free memory (of 1.6GB), about half of RAM used (can’t see a number) and the load average is usually around 10%.
Homey version is 2.5.2 and app version is

Before I give up and return my Homey, I want to try to find the cause of the error and see if it can be fixed. I could also try to reset my Homey, but I have many flows that I don’t want to re-do.
But I don’t know how to get a log or anything from the Homey? Any ideas on troubleshooting?

Have you tried removing the device from Homey and adding it again?

Yes, several times and with different devices.

Hi Oscar.

Is it one specific brand that do not work or several brands/models?
Do they respond when you test the flows from the app?
Did you reset the devices before adding them again?
Can you change channel on the devices?

BR, Johan.

Ps. jag ser att du troligen är svensk, om du vill är du välkommen till den svensktalande facebookgruppen Homey Homies där vi är tusentals glada Homeyanvändare som delar med oss av tips och tricks och hjälper varandra vid felsökning m.m.

Hi Johan,

There are several brands. Two Telldus (using the Telldus app) and four Luxorparts (using the Clevario app). Surprisingly, the Luxorparts works the best.
They do not respond when testing flows (or the flows themselves)
I have tested both un-plugging and re-plugging the devices, resetting them (holding their switch) and removing them from Homey.
I don’t know a way to change the channel.


P.s. Tack för inbjudan, men jag har ingen Facebook.