Homey Community Forum

Lights before sunrise

Hi, I just started with the homey bridge and create a simple flow:
At 06:15
And before sunrise
Turn on lights (kaku)

However the flow doesn’t seem to go past the before sunrise part. Although it currently isn’t past sunrise at 06:15. I don’t understand why this isn’t working.

If I change it to: (then the flow does work)
When this flow is started
And before sunrise
Turn on lights (kaku)

Can anyone help?

Kind regards

If you haven’t already then report it to Athom
support@athom.com

If I remember I will test it tomorrow morning on both Homey and Homey Pro to see if I get the same problem.

Try a flow that only triggers on a specific time (without the sunrise part) and see if that works. If not, perhaps the time settings on your Homey aren’t correct.

1 Like

Try testing the flow now (after sunset), check if the condition is marked with a green checkmark. If so, flip the condition, so it checks ‘after sunset’.

Unfortunately I had the same issue, this worked for me. Seemed like a bug in this card (using bridge)

Now I am using the condition ‘is nighttime’ which seems to work correct. Current flow when motion is detected on the stairs:

EDIT: made an example for you, ran this test a few minutes ago:

The conditions are marked as valid after testing now, but I am quite sure it is before sunset and after sunrise…

I think on the bridge we don’t have the option to change time settings. Don’t know where the servers of homey are were our flows are running, but maybe that has something to do with it…

On Homey Pro you also can’t set the time/date directly, Homey finds the correct time for the location that you have configured.

Please let Athom know that there’s (yet another time/date-related) bug in the current version.

This will only work when Sunrise is before 6:15 (european summer)

Thank you all, for the help. Inverting before Sunset works.

1 Like

How do I do that?

If the reason is the same as for me, it is because he does not want the flow to trigger when it’s after 0.00 for example. I am using this for my motion triggers lights in flow when I come down in the morning. I don’t want the lights to go on when I go to bed one day after 0.00

  • Configuring your Homey’s location is done in the mobile app settings (don’t use “Find Homey’s location automatically”, set your location manually)
  • If you think Homey has a bug, you can send an e-mail to support@athom.com
1 Like

Thanks for explaining, but I didn’t ask for that, every one has his own reasons for wanting something, for me, that is personal.

Did u fotoshop this @Sapperdeflap ?

chrome_0k6f9VCLXu

No photoshop, this is how it works on my app, location is set to a Dutch city, so time should be GMT+1

Ok

Ok. Was wondering about the “zonsonderhang”. Bug or fotoshop?

1 Like

Confirmed (door @Dijker) bug in de Cloud versie.

Really? No kerstpakket for the guy who wrote that bug. Bug=typo?

Typos zijn text bugs :stuck_out_tongue:

1 Like

Would agree on fixing the before/after bug first before the typo though :laughing: