Light dims in seconds, instead of 20 minutes

Hi all

So I made teh switch to 2.0. Nice app, really really love the look.
However, I made a new flow with the sun event app, when dusk enters, it has to dim te lights smoothly in 20 minutes.
However, it just jumps immediataly to the dim setting.Screenshot%20(8) Screenshot%20(9)
Any tips?


And what kind of lamps (make and model) are u using?

excuse me, good point. I’m using philips hue lights

Was just curious because i just tested this with a Hue E27 color and that works just fine. Am using another card tho, the “dimming to” card. When i use the “set temperature” card it indeed turn it to 100% in a second.

1 Like

I think it has to do with the lights not using a tempreture value for their colour when you give them a “colour temp” command. That is how I got it reproduced,a s soon as you add "temp"it bugs.

You only need to add the duration for the dim level, so try removing them from the temperature flow card.

but I also want to change the colour, so I need both right?

It is odd, my morning routine also jumped up once I try to set something like colour or temperature.

Yes you do need the card, but just without the duration, it will take/use the duration of the dim card

what? the colour card will use the same amount of duration as the dim card?
sorry I feel stupid but I changed nothing but the behaviour changed, so now tryig to understand again :slight_smile:

It simply doesn’t want to work? Maybe I need the beta for philips hue or something.
because it doesn’t matte whether I set a delay, duration, both or none, it jus jumps immediately to that setting.

Do you usw the beta version of the Philips app?


oh,t hat is even older than on the store. I can’t return to that version :S.
bugger. I just can’t get the lights to dim

And ofc u tried the suggestion of @Caseda to remove the duration from all cards but the “dim to” card?
Or even remove all cards except just 1 “dim to” card and set the duration for just that 1 card and see what happens? And for testing use just a few minutes :wink:

yes, I did actually :slight_smile:
When I put a duration only it works, but as soon as I add a delay, it just pops

A delay should have no effect on this, it only delays before activating that card, and is completely out of the app’s control (so far away that the philips app doesn’t even know it was being delayed).

I now start thinking something else is wrong, have you tried rebooting the hue bridge?
Or any other flows that could interfere?

I’m also thinking that now.
Yeah. I did a reboot. And other flows. Hm. Not really, as in, my test flows were in the middle of the day (no other flows running). Might consider resetting homey and start clean. Hmm

In my experience with Homey since the beginning the delays in cards work… sometimes… but mostly incorrect. For instance, I turn on the lights in my hallway when motion is detected and have a card after that that turns them off after 3 minutes. Sometimes it works, but most of the time it turns them off much faster, sometimes even within 5 seconds…

REALLY annoying and Athom should really fix this… after years!

I have tried this with Hue lamps and with Z-Wave and both have the same results, so the error is not in the apps but in the ‘delay’ implementation of Athom in the Homey Firmware.

If motion is detected at 10:17 and then you come back into the room 4.5 (10:21:30) minutes later and motion is detected (again) ~ how long would yoh expect the lights to remain on?