Knx not work

I purchased and installed the new homey pro. I have a knx controltronic router, so it supports multiple connections and in multicast. It is recognized by the app and I am allowed to configure knx addresses but yet the switches do not work and neither do the temperature readings. Ets works correctly by connecting to the knx router. Support does not respond to me. I would like to understand where I am wrong or if the integration with knx is not working.

There’s a lot of KNX posts when I searched for it here, did you check any?

While I was reading a bit, I think this can be interesting:


How did you contact them? In theory should receive a ticketnumber the same day.
At the moment they’re pretty busy:

Screenshot from 2023-06-12 04-46-19

I read all the knx posts before writing. In no post is a solution given, in fact in many the problem remains open. I know the knx system well, I know how it works, I have designed and programmed mine and it works well with a knx server.
I have as many as two unanswered tickets for a week. I purchased homey pro in November, received it a month ago and have been going crazy for a month to get knx working which is critical for me. It occurs to me that it is not compatible with my knx router, but nevertheless it should not need a specific interface. At least that is how it is advertised. On such a crucial app you can’t leave customers waiting for weeks.

Hi Guglielmo, mine knx works like a charme with my homey. Maybe i can help u, pm me.

Hi how I can pm you? I think that we can speak Italian. I followed all the steps in the guide but it doesn’t work. How can i provide information to help me? i entered the address of the knx router. then i loaded the age and entered the correct addresses both command and status. but it tells me: switching device failed.Nothing happen. I can send you some screen of the process and settings.

Exactly we can speak italian and after solved i would show the solution here for the community. If you click on my name you can send the direct message.

You can also discuss it in the Italian forum part, in case you didn’t know about this possibility:

1 Like

It is a great idea, @Guglielmo_Rossi please open a case with pictures in the italian parts, and i will help you over there. :wink:

1 Like

I have exactly the same problem and same error message. I even bought the weinzierl 731 knx ip interface which was sold some time ago by athom as knx kit and it still doesnt work. If this wont work soon i will have a homey pro 2023 for sale

In my case i use this controltronic unit and works perfectly. In the middle i have a router fritzbox 7950. So exactly what Is your issue? Can you attach some screenshot so maybe i can better understand and maybe help?

We have fully functional knx system but homey 2023 not work with knx. I have another old server(ikon)that work perfectly. No support is provided. No tips.I suggest at any customer that want use homey with knx to not buy homey pro now. The lack of support is the worst part.

1 Like

Please answer on italian forum Problemi con knx.
Athom don’t give SUPPORT for any configuration, for help you on config this is the right place. I’m only a customer and my KNX work perfectly with HOMEY PRO (2023).

For all those with KNX problem, remove homey’s ethernet adapter and hook up homey via wifi. KNX working!
workaround for now!

1 Like

Hello @Guglielmo_Rossi happy to see you fix that.
Mine work fine in ETH but can expect to have different network on every installations so, who know :wink:

No the problem is related to the connection. And Atom,now, is investigating the problem. If one configures homey from the beginning only in ethernet and not in wifi, as I did, KNX does not communicate. If one initially configures wifi and then hooks up the ethernet adapter then it works. The thing is that Homey seems to be able to use both network adapters, and so it needs to be understood if the Knx module continues to use wifi even when ethernet is connected and so it seems to you that it also works in ethernet. There is cleary a bug in the knx app and in how manage the network adapter.


Dude! Finally someone who knows what the problem is. THANKS!
I used the ethernet adapter from the beginning and it never worked… till now
contacted athom support… no result…
spent 200 € for the weinzierl, still didn´t work.
now connected via wifi, IT works!
very bad work athom!

I also tried this but it didn’t work for me. Have the Homey pro 2023 newly installed but get to see ip gateway in the app and can also switch in the app but nothing happens at knx level