KNX light switch seems to work but it doesn't


I got my Homey Pro a few days ago, and now I’m trying to integrate my KNX devices.

The electrician didn’t give me the project file and I couldn’t contact him :confused:
A few month ago, I tried to integrate the devices with openhab and homeassistant without too much success, but I could get most of the groupadresses.

I tried to add several devices, but the result is the same :
When I try to switch a light, nothing happens in “real”, but on my touch screen (configured by the electrian), it “works”.
If I switch the light with the wallbutton, I see it change on homey.
So it seems the groupadresses are indeed correct… but something is not correct?

Thanks for reading, and sorry for the long explanation :slight_smile:

Ok, I found myself the problem :
As I got the groupadresses “watching” the bus, groupadresses of the lights themselves and those of the switches were mixed together.
After some testing, I managed to found which is which, and it starts to work :slight_smile: