KNX application not working

Hi,

I just bought Homey, and is trying to get it to work with my KNX system.
Unfortently things are not working as they should. It seemd to me that Homey is not sending the packages correctly to the KNX bus.

To make it simple, I tried to set up a single switch, to turn a light off / on. To check whats going on, i`m connected to the bus with ETS and is watching the group monitor for traffic. When I am pushing the switch in Homey, I can see that it reaches the bus, and is sending the correct group address and status (on / off). However, the Service is marked as “From Bus”. So it looks to me, that its just reading values from the bus, and not actually sending the values to the bus. See attached screenshot, where you can see 15.15.21 is getting information from the bus, and therfore the light is not turned on / off. After that i tried to do the same thing in group monitor, where you can see 15.15.15 is actually sending the value “to bus” and therfore turning the light off / on.

Have anyone had the same problem, and know how to fix it?