Homey / KNX issue


I have a problem with my Homey / KNX integration, and I hope someone here can help me.
I have connected my Homey Pro to my KNX system via a KNX / IP interface (Schneider SpaceLogic KNX IP interface). The IP interface is detected by Homey, and my KNX devices are also added to Homey. The KNX device statuses are updated in Homey when there is a change in the KNX system, but I cannot send commands from Homey to my KNX system. The interface works well with ETS, so there are no problems there.

Thanks in advance!

Best regards,

1 Like

Are the switch addresses correct?

Hi Mark,
Yes… I’ve also checked the group addresses in ETS to be sure.

Hi Lars.

did you solve this problem.? Have the same problem, which KNX system are you using.?


Same problem with xxter KNX gateway. In addition to some (not all) sensor data i am able to ”almost” turn on switches - they switch on and off in the xxter Knx app but the real light remains off - no telegram seem to reach it. For dimmers nothing happens…. So basically same problem. Some indications that data is flowing between homey and Knx - but cannot send commands….


It seems I have te same problem.

Would you have found any solution or even explanation ?

Hi Guys,
Sorry for the late reply.

No, I have more or less given up hope for this to be resolved. It doesn’t even seems like the Homey team are interested in looking into this issue at all. I’m very disappointed both with the product and the support in this case, as they claim to have full connectivity to the KNX system.
So for me this “cheap” solution became expensive because I paid for something that I can’t make use of…


1 Like

Hi Lars,

Disappointing indeed…
I got my homey pro only 4 days ago, so I still have 3 weeks to test and hope…
But otherwise, I guess I will return it :
Without KNX, there is no point keeping it for me :confused:

Hi Lars,

I don’t know if it can help you (or somebody else reading the post), but here is how it started to work for me
(Still some work to have it really working, but I could already switch a light from a flow)

I got the groupadresses by “watching” the bus, and at first, I hadn’t understood that both groupadresses of the lights themselves and of the switches were mixed together.

For example, when switching one of the light with the wall switch, I had 1/0/4, 1/1/4, 1/2/4 and 1/3/4.
So I have to figure each time which one is

  • the light switch address
  • the light status address
  • the switch switch address (very clear :slight_smile: )
  • the switch status address

Hi @LAAL , I have homey since July 2019. I bought it to substitute a terrible system received with my apartment. Under this system there was knx, so I choose homey because of the compatibility with knx. Open speaking I had very big problems in the first 6 month, extremely unstable. Then the situation improved a lot. Anyhow I decided to use shelly to controll of my heating and cooling systems, since knx + homey was not reliable enough. so now only lights are controlled via knx. I must say that in the last two months I saw again quite a big instability even if generally the system come back to normality without any activity. It remains however that during instability you can not command any lights (via homey) and this is very annoying. In my building we are six with homey and another things that definitely create problems are the routers of Vodafone. While I use my own router, my friend use the original of Vodafone. Each time homey restarts for any update, it looses the connection with knx ip interface and it needs several activities before you have again the system working. With my fritz I don’t have this issue. Then you are right, it seems that knx is not intersting for Homey teams and I’ve never found any real support each time I had problems. As I said at the beginning, in the last weeks I see that quite often knx devices start to get the red exclamation point, then after some minutes system is back again. Unfortunately if this becomes frequent you have system that is not responding and homey that I totally keen in reconnecting with knx adsorbing a lot of resources.

1 Like

Hello Everybody,

The last weeks my homey knx (kit) has also become very unstable. Is there any progress in honey knx and/or the homey knx app?

Hopefully somebody can give any support.

Thanx a lot

Best Regards Johan

Is there any support on this subject?
I had a working system last week.
But in the last days I added more KNX devices and programmed a lot of advanced flows to copy the functionality of my Gira Homeserver 3 to Homey.
Now that I am ready, the connection between the homey and KNX is intermittent. Sometimes red exclamations or when I change the status of a device, nothing happens.
This is frustrating as flows need to preform there actions on the KNX.

Is there a limit on the # of KNX devices in Homey?
Is there a limit on the # of KNXbus telegrams that can be send or received?


Hi everyone

I think I got it working.

First of all, the KNX IP gateway can be installed on a DIN rail, but if that is within your electricity box, then your LAN cable is running next to the powerlines and can get interference.

Since I installed the KNX IP device outside my electricity box, the connection is more reliable.
Or you can use a shielded UTP cable that can run with the powerlines.

Secondly the KNX protocol is run as multicast. Your router and/or switch has to support multicast. Please find more info for your router how to enable or to tweak that.



Anyone here got success setting up KNX with the IP Interface MDT SCN-IP000.03 ?
It´s IP was found when adding it as device in homey but if i want to switch a device a just get the message “switching the device failed!”
Any other home automation software i used before never had a problem with this interface and worked flawless… i hope i get it to work otherwise i need to return the homey pro.


Many thanks for this tip @KevinC! For me this was the solution.

For months I’ve been having similar issues with our Homey-KNX stability as others describe here. Frustrating things was that it used to work fine, but the stability seemed to degrade over time. Then following KevinC’s advice, I changed the UTP cable between the Weinzierl IP Interface and my switch to a STP (shielded twisted pair) UTP cable. Since that change everything works perfectly again!

In my case the IP Interface is still inside the electricity/fuse box, it wasn’t necessary to take it out. But like Kevin pointed out, that could be another solution for some of you as the issue does really seem to be the overal stability of the hardware and interferences along the way.

Hello ,

did you find the problem ?

Athom support told to do the fix , bring the Gateway out of the electrical box

But with home assistant everything works fine

I am also frustrated with the limited setup documentation and support. I have a completely new KNX project that works great. Bought homey and haven’t been able to make it work. I have an HDL ip router. No matter what type of device I add, all I get is “switching the device failed”. My ip router is recognized, multicast is on, my cat6 is shielded.

Any help from the community or homey would be greatly appreciated

I have a KNX installation with Gira Homeserver since about 10 years. My Homey Pro arrived at June 2023. My electrician installed the KNX IP Interface (ordered here). I believed everything worked fine from the start (no installation issues).
Swithing on or off lights works fine via Homey. But If use my original app (Gira) to switch lights off or on via a kind of flow by pressing switches on the wall, the status of the lights are displayed incorrectly in Homey.
I have a Telenet (CV8560E) modem/router and I use Unifi USW switch. Multicast enhancement on or off, it makes no difference.
A temporary (dirty) solution is to run each X minutes a homey script I’ve written to get the status of each KNX device by a Gira API and set the correct status in Homey (if it’s wrong).

What should I do to prevent the incorrect shown status. Is this a bug in the KNX interface, KNX Homey app or Gira?

Overall, Homey is fun to play with, just a shame the device and/or the apps have a lot of bugs and you can’t 99% rely on it.

I don’t think it is a bug. When you switch on a light via Gira, Homey just does not know, as Gira does not even know there is a Homey. It is just not designed that way.


The status only doesn’t change in Homey if I use some kind of flow in gira (e.g. all lights out). When I switch off a specific light via Gira, the status changes in Homey.