KNX doesn't work

Hi everybody,

I’m trying to connect Homey (2.0) to my KNX system. App was installed, devices were successfully added but they don’t work and don’t send any telegrams to KNX system.

Any suggestions where to look and what to try?

Best regards,

Check the ip adress of your knx-interfacein the config of your devices on Homey. Noticed that the app found the interface, but didnt “save” the ip adress, only the MAC, in the device. Had to manually add the adress after every device creation.

I’ve checked devices settings, IP address is set and correct.

I have the same Problem. Status is reported correctly but nothing sent to bus.
Contacted Athom multiple times with no success.

They’ve sent my request to their KNX team. So I’m waiting for answer … and waiting and waiting :frowning:
Actually without KNX integration the device is useless for me.

Al also asked for the git-Repository to check and fix it by myself.
But KNX has no open git repository.

So stuck at this point.

I’ve been using the KNX-app for a while without any problems. With both 1.5 version an 2.0 of Homey.
Which app-version are installed on your Homeym and are there multiple KNX-interfaces or routers in the installation?
If there are routers used with filtertables from IP to TP-line check that the filtertables let the telegrams through the coupler.
And also check the multicast-adress of your installation. Make sure it’s on default adress.
Could be good place to start.


Latest version of Homey and KNX app. One IP-KNX interface, ETS is working fine with it. No any filters at all.

What do you mean “default multi-cast address”?


Hm, thanks to navigate me. I’ve changed my IP-KNX router mode and it starts working.

Perfect! But it should work either way.
And another thing to have in mind:

  • if connecting with tunneling, make sure the interface have possibilities for more than one concurrent connection. If it’s only one tunneling connection possible on the interface, the ETS5 takes the connection and the Homey dosen’t communicate with the KNX before the ETS5 disconnects, and the KNX-app on Homey restarts.

It should but it doesn’t :slight_smile:

I’m using Logic Machine as router and Homey is working when it is in “EIBnet IP Routing” mode but doesn’t work with “TP-UART” mode. ETS is working with both.

Using knxd. There ist no Filtering.
Ets, Node-Red, Zipato, Openhab2 are all Wirkung
Without any Problem.

But Homey only receives Status but does mit send any

When adding a device i get an error " Homey is not defined" when pressing the device button.
Adding a device is not working in Homey 2.0.
I also have to restart the app every 2 days. It seems to lost connection?

Did you solved the problem, I have the same issue.

No, the problems are not solved.

I have send a couple of diagnostic reports to Homey.
The are working on it but they are very busy with Homey 2.0.

I have tried many things on the KNX hardware side such as:

  • another IP/KNX interface
  • Another KNX powersupply
  • Other network cables.

The result are still the same. I my opinion its the KNX app that is not stable.

They are (incorrectly) sending the “A” flag for every message to the KNX bus. Most KNX systems just ignore these messages.
I provided them detailed KNX bug logs and device logs but it seems they are not working on it.

Sigh. Another month gone and nobody working on the ticket…

I’m thinking to drop Homey to garbage. I’s completely unstable, sometimes it is working, sometimes not. Some features can stop working after the new update. So I can’t left my house on it. Really good idea but so bad realisation :frowning:

Dear all,

topic is old, I know. But suffering from the same problem(s) for about three months, I wanted to share my status quo.

I tried differnet IP Interfaces. Ended up with the MDT IP Interface - current version. That supports up to 5 simultaneous connections via tunneling. I could see that sometimes ETS and Homey App tried to use the same tunnel (physical address). That is when I got the red triangles on some of the KNX devices in homey.

My thoughts:

  1. Using an IP Router with Multicast instead of an IP Interface should work - I don’t want to spend the money for that though.
  2. I set up now knxd in Docker on my NAS in addition. Homey only received telegrams first, since I changed the knxd physical address to 0.0.1 Homey started sending telegrams too.

In case anyone is interested… I keep you posted.