KNX gateway overload?

When I start a flow that sets 50 KNX dimmers to a certain dim level always about 5-10 dimmers do not react. The dimmers involved seem to have been chosen randomly. I need to start the flow once or twice again to have all lights turned on.

Now I’m sure that Homey sends them all out. All lighting icons light up in the app. When looking in the bus monitor within ETS however, the lights that are not turned on are missing!

It seems that my KNX IP interface is bouncing some commands, probably because it receives too many of them in too little time.

I was wondering if anyone else has run into the same problem or if someone can think of a possible solution.

Homey has troubles with commanding more than X devices in one go, at least with zigbee.
Maybe setting 50 dimmers at once is too much, either for Homey or the KNX GW.

You can try to delay every group of 5 action cards f.i.
set dimmer 1
set dimmer 2
set dimmer 3
set dimmer 4
set dimmer 5
set dimmer 6 with 1 sec delay

set dimmer 10 with 1 sec delay
set dimmer 11 with 2 secs delay

set dimmer 15 with 2 secs delay
and so on.

It’s a bit trial and error, maybe the example can be used for setting 10 dimmers at once, or 15. Then fiddle around with some delays.

So how do you conclude that Homey sends them all out? It seems to me that Homey thinks it sent them all out, but it didn’t.

As already pointed out by @Peter_Kawa, Homey isn’t very good at sending multiple commands from a flow at the same time, commands get lost somewhere in Homey (and since this issue has existed for such a long time now, apparently Athom cannot fix this).

Wow, I didn’t know that. This affects the robustness of the app so much and it seems so unlikely to me that it would be hard to resolve. Maybe just a general setting of a delay between commands or something like that might help.

I don’t think Athom has even acknowledged that this problem exists, even though a lot of Homey users run into it. The issues started with Homey firmware v2, where Athom rewrote the flow handling. That was 3 or so years ago. Given that the issue still exists, I have to conclude that Athom is unable to fix it, and unwilling to implement a general workaround.

Two more workarounds:

Thanks for the tip! Using the app with a 100ms delay seems to be a work around for a Homey bug.

1 Like

Does using 3 separate flows actually work around the problem? Because you’re basically starting 3 flows within milliseconds of each other, and each flow is switching 3 lights, so you still have 9 or 10 lights being commanded at almost the same time.

I didn’t try that but if there is a delay of x msecs before a flow is started, this might very well work. For me though, this would be too much work and my flows would become too complex and hard to maintain.