ITEAD Sonoff

How have you configured the device in the Tasmota config (the module type, specifically)?

The Sonoff app doesn’t support the SV directly, but I think it should work if you configure/add it as a Sonoff Basic (both in the Tasmota module configuration, and with the Sonoff app).

Sonoff SV works perfect if added as “generic tasmota”.

I’ve set my sonoff in “Sonoff Basic” mode and now homey discoveryng the Sonoff :smiley:
It’s work perfectly. Thanks

I bought some sonoff basic switches. Anyone who has ever tried to connect them with the present wall switches successfully?

I mean, would it be possible to use the sonoff as well as the wall switch?

Hello. I’ve bought an AWP07L module, originally have a tuya firmware and with tuya-convert i’ve Upload a tasmota firmware and now is a module with tasmota and work very well.
I’ve correct set my MQTT brocker and in webgui i view the correct powermeter parameter, but in homey app I don’t view the power meter parameter, and is necessary for me for the flow.

I’ve set my module in tasmota-generic.

Thanks for the support

The power meter capability isn’t supported, I’m afraid (it’s shown because the driver knows that the device has power meter support, but actually reading the power meter data isn’t implemented).

You could look at this topic for a possible workaround.

Hi. Found your message when running a search for eWeLink. I recently bought 2 wifi light switches that are controlled with the eWeLink app. I can connect them in Google home, but can’t seem to get them to work with Homey.

Any suggestions?

Thanks. Emile15598271551328500514214952444673

eWeLink devices are not supported by Homey. Sonoff devices are only supported when you flash an alternative firmware (Sonoff-Tasmota) to them (this may work for other eWeLink-driven devices too, but can’t promise).

Hi Robert,

Thanks for a nice app! I’m using a couple of Tasmota basic switches.

The newly released DIY mode looks very promising. They are talking about LAN access and “works without internet” so I should think this is the way to go.

This is the official documentation;

Hopefully we won’t have to flash these devices soon :slight_smile:

To be precise, here is the good stuff;

The devices auto-connect to SSID “SonoffDiy” and will work offline :smiley:

This sounds really interesting! Would be great to not have to flash them - I have a few old ones that work great but have held off buying new ones due to this!

Is this an update that is coming to all modules or only specific ones?

Sonoff Basis R3.
The device in the docs look a new device?

So it won’t be possible on current devices?

Hi All, i still had 2 devices of sonoff. 1x rf and 1x wifi. Just checked them today if they worked and they do.
Can ad them into the Ewelink app and can use them thru google assistent. I did had an update from 1.06 to 3.01. Does this mean i have that new software now. Does this change anything so it can be used with homey or is flashing still the only option. My knowlegde of this is not so good so sorry if i am asking something stupid :relaxed:

Flashing is still the only option, I’m afraid :frowning:

hm to dificult for me. wil leave the homey part then and only use it thru google assistent. :face_with_raised_eyebrow::face_with_raised_eyebrow:

@robertklep how is that new DIY stuff looking from your side? Will it mean no flashing needed?
I’m in need of a mini switch/relay for an extractor fan, and sonoff would be by far the cheapest way to do it if I could control with Homey!

I haven’t looked at it at all, not sure if I ever will because I mostly stopped using Homey.

:frowning: Sad to hear

Out of interest what system have you moved to?

Home Assistant. I moved to it when my Homey got bricked when I upgraded from v1 to v2, and had to send Homey back to Athom. During that time (about a two week period) I moved everything to Home Assistant (I already had Zigbee and Z-Wave USB sticks) and never went back.

Can’t connect Sonoa basic,

Mqtt connectie kon niet gemaakt worden.

Do you have any idea for me?