Invitation already accepted - Family sharing issues with 2.1

I’m experiencing issues with family sharing that I cannot find anything about in any other thread. Hence starting a new one.

I am trying to invite a family member to my homey. Link is shared, user accepting has an account already, installed the app and is signed in to the app (but not yet linked to any homey). When link is clicked the error message “This invitation has already been accepted” appears. This happens for every link I share. On my side the name of the invited user is changed from “Awaiting confirmation” to the name of the user that got the error message. But, the user doesn’t get access to the homey.

Anyone experienced this?

We’ve tried everything we can come up with including clicking the links signed in or out of the app, reinstalled the app before and after link was clicked, removed the account and re-created it.

Did you already fix the problem? I’m experiencing the exact the same thing.

Unfortunately not. I’ve tried some new browsers but no difference.

Maybe somebody else can help?

My best guess is: Opening the link by accident by the owner invalidates it. Just create a new invite link and send the link, let the invite register an own account, install the mobile app and open the link.
That’s how I did it. Just remove the old pending invite as owner.

1 Like

I had the same problem. When reading your post, I see you are already doing it the right way (having an account and being logged in when accepting the link). Perhaps you could try sending the link in another way. The first time, i sent the link via whatsapp. That didn’t work for me. But when I sent it using bluetooth, it did work somehow.

As Dijker says, just revoke the old invitation and send a new one and perhaps try another way of sending the link.


Thanks for your replies, sending the invitation link by Bluetooth worked for me!