Family link Homey 2.0

I’m trying to share a family link with my girlfriend, but when she openens the link the app opens and the nothing. I’ve tried this when creating a account for her and when I login with my account it also doesn’t work. Is there something else I need to do?

Me too. It never worked for me during the beta.
But now they have released 2.0, it still doesn’t work.

The link you share just sends me to the app store.
When you open the app it never knows about the referal token in the link.

I filed it with
I’ll keep you updated.

Will follow this topic, having the same problem.

For me this was fixed the day after. You need to make sure the other person already has a athom/homey account and has authenticated in the app.

1 Like

With the latest Homey 2.0 Firmware & app it works for me now too.

Create a 2nd account for the family member.
After logging in you should see a popup “You have been invited”

If no succes:
Try to log out the new account on the 2nd phone.
And then click the invite link on the second phone (which opens the app) then log in with the new account.

Before I also tried it on a Nox player.
This didn’t work because the invite link always sent me to the app store, even when the Homey app was already installed.

I have tried all the above options on different devices but I keep getting the screen that no Homey is connected.

The status is also ‘waiting for confirmation’

Any ideas left?

I have the same problem and have spent days trying to figure it out. If I open the link on an Iphone it starts the app, but it just says the user has no Homeys. If I open the link on Android (Huawei) I am taken to the app store.

How is this supposed to work?

I have had the same issues myself. After a while I decided to try it again when on 4g so no WLAN connection. This worked. It looks to me as if my local pihole DNS is dropping a certain url and therefore the process can’t be completed.

I send my findings to athom and I’m waiting for an answer on this.


Added a new family member in 2.0.4 today without a glitch. Tried it yesterday, but because we both have the legacy app under my account, this was somehow remembered when installing the new 2.0 app.
Today i tried again and used following steps (via an Android phone):

  1. Send invitation by WhatsApp
  2. install/open the new 2.0 app (if you are logged in with the wrong account, then logoff)
  3. chose “create account” and complete this
  4. log in with the new account
  5. click on “you are invited”
  6. Done, you are added as a “user”
1 Like

Have tried several attempts to create an account using the app - and it always failed. Whenever adding the account details, it stops at the final step - and you´re lost… What to do here? Should be a simple way to add users…

Tried above steps? Sure it’s on the phone of the other user? Sure old versions of the app are completely uninstalled? What phone/os is used?

Are you using any add blocker or things like pihole? I noticed that one of the domains that is used for the link resolving is blocked by pihole.

Created the user on the web instead, then it worked. But it failed consistently using the app, both on Android and iOS.

I am too having issues with adding a family member. I’ve followed the steps provided by user PetervdK:"
Send invitation by WhatsApp
install/open the new 2.0 app (if you are logged in with the wrong account, then logoff)
chose “create account” and complete this
log in with the new account
click on “you are invited”

This is a total fresh install / account creation on a phone which never had any Homey apps.
On the invitation pop-up, a different name appears: “… has invited you to use …” when I click the link an error message in red appears: “homey_offline”.

I am having the same problem on one daughters phone. But my wife and other daughter worked fine.

Have you solved this?

Yes it’s solved, Athom released an update of the (iOS) app and afterwards everything went ok and I was able to set up the family sharing.


When was this? I tried yesterday with the same problem.
Best regards


About 8-9 days ago? Have you already tried deleting the current invitation and making a new one?

Hi, I erased the account and created the account again and did a new invitation and FINALLY it worked. Thank you

Best regards