IKEA Gateway


I have just unboxed my new Homey and i am trying to add devices works fine with Sonos. am now trying with IKEA trådfri gateway, pressing this icon i get 4 options Group, Light, Plug and Roller blind as i have all these devices i have tried them all. the message i recieve is that i shall configure the gateway first. I have given the gateway an static IP as per instructions found here but i cannot find anything else to configure. What to do need help am frustrated looking forward to a solution


Go to the app’s configuration screen: “More > Apps > IKEA Tradfri Gateway > Configure app”


Many thanks still not working Gateway seetings in the app when hitting the Discover icon the IP adress shows, assume that this is OK but the PSK number is that the 16 digit number/letter?


Got it connected so i can now see all my IKEA groups together with sonos etc, but when hitting the IKEA icons i get the message recieved fatal alert: undefined

what to do

Well, I tried Ikea gateway but did not like it and unistall. Unfortunettly ikea gateway accessories are still visiable in Homekit (although not in Homey). How can I delete it? tried to delete and add Homey as a hub but still after adding it wants me to add all the Ikea gateway accessories…

The IKEA gateway itself also supports Homekit, so it’s unrelated to Homey. Does Home show an accessory for the gateway that you can remove, perhaps?

Nope, bunch of “default devices” are added only if I add homey to Homekit. It were created by Ikea gateway app for homey and after unistalling app, still are added to Homekit via homey, eventho the aren’t in Homey currently

Which Homekit app/implementation do you use for Homey? It doesn’t make sense that a Homekit app would provide a device to iOS that doesn’t exist anymore.

Agree. I use experimental feature.

The experimental feature is created by Athom, so it might be wise to submit a support request through their web form: https://support.athom.com/hc/en-us/articles/360015784034-Submit-a-support-request

thx, apart from experimental, do you recommend Homeykit or Homekit app?

The Homekit app doesn’t work on firmware 4.2.

OK, I’ll try to disable experimental and instal HomeyKit