How to set up IKEA tradfri gateway app?

I’m new at this, and cannot for the life of me figure out how to set up the gateway app - have done my due diligence, but cannot fond a recipe. I bet it is real simple- as the developer hasn’t even put up a ‘how to’ guide.

I put in the security code and the IP - I have made the IP static in the router.
PSK I have no idea what is. How to find this?

I have tried without, but get error message ‘error: not_found’.

Appreciate the help - or a step by step guide.

Best regards
The n00b
(Have searched the forum without finding a similar topic).

How I did it.
Make the tradfry static in the router.
Go to the config of the tradfry gateway app.
Discover the ipadress.
Than enter the security code and press authentice.

After that I can add the lamps zones and plugs.
Oh one other thing if you reboot homey and your bulbs lamps etc is not reachable reboot the app once.

1 Like

@Snippem’s answer is correct. The PSK is the code that is returned by the gateway after proper authentication, so not a value that you have to enter yourself.

The not_found error is not something that it returned by the IKEA Gateway app (at least, I cannot find any reference to it in the code) and might be generated by Homey itself for some reason. Try restarting the app (or even Homey) to see if that solves the problem.

1 Like

Thank you @Snippem and @robertklep! A quick reset did the trick.
I am running Google mesh network at home, and I had plugged the Trådfri to a separate switch connected to one of the Google nodes - when I connected Trådfri directly to the node it solved my issue - but not before restarting the app.

Ok, I’ve had my homey for almost 15 minutes so please bear with me… Where do I find this security code?

On the bottom of the hub?


Thanks. I’m unsure whether to feel more stupid or grateful :stuck_out_tongue: I have to admit I didn’t look under it simply because I’ve looked under it a ton of times before and couldn’t remember seeing anything about that.


I am having trouble setting up the ikea gateway app, and I know comparatively little about networks so bear with me please.
I have set up a static ip (in the settings for the router) where I could enter the ip (starts with 192) and the mac address for the gateway. IKEA writes MAC NR ETHERNET on the gateway and there are no “:” so I added those.
In the homey app I have tried adding a device, choosing ikea gateway as the app and get a message like configure the gateway first. Found the app in the settings tab in homey where you can set gateway settings. There is a button “Discover” with Hostname to the right of it. If I press that nothing happens, and I find the settings page confusing.
Greatful for help!

Ok, got it - had to plug in the gateway with the cable to the router :slight_smile:
But now next problem I can not connect the plug, it says no new devices have been found, and it says so rather quickly.

Well you probably have not yet connected any ikea bulbs etc. to the tradfri hub since you just plugged it in the router. Did you use the ikea tradfri app for android or ios already?

I did try with the (homey) ikea tradfri app on android first but things got disconnected, and as I saw many people were having problems with this I decided to buy a gateway and use the ikea tradfri gateway app. But when I click on add device, choose ikea tradfri gateway app, then choose the outlet, it says no new devices have been found

3 or 4 other brands were very simple to set up but the ikea stuff…

1 Like

Like @Michael is saying: did you actually add all your IKEA devices to the gateway first?

The correct sequence is:

  • connect the gateway to your home network
  • install the IKEA app on your mobile phone
  • add IKEA bulbs/sockets/etc to the gateway using the IKEA app on your mobile phone
  • install the IKEA Gateway app on Homey
  • configure the IKEA Gateway app so it will connect to the gateway
  • add devices in the Homey app (choose “IKEA Tradfri Gateway” > “Group/Light/Plug” > “Install”, and you should be presented with a list of devices of that type that are connected to the gateway)

Thank you! In the ikea app (Home smart tradfri) I added a motion sensor (only inputs can be added) then two lamps to this. Then in the homey app (IKEA tradfri gateway) I added a group (the two lamps) and now I can control this group from Homey.

So in the ikea app (Home smart tradfri) to add a device you also have to choose an “input” like motionsensor or a remote. No way to add an outlet by itself?

From what I remember from adding IKEA devices to the IKEA gateway (it’s been a while), you need at least one input device, for instance a remote. This remote is used to associate other devices (like bulbs) with the gateway, and is linked to a room in the IKEA app.

However, once the device has been added to the gateway, you can create new rooms in the app and move the devices to that new room. This will disassociate the device with the remote that you added it with, so you only need one input device to add all your devices, as long as you move them to separate rooms afterwards (in other words: you have one room that is associated with the remote, and newly added devices are added to that room, but once that’s done you can move them to other rooms).

Within the Homey app, rooms are called “groups”.


I have the ikea tradfri gateway set up and working but I have one problem.

If wanting to create a flow to turn specific devices off (Device type - lights, in a specific zone), this does not work. I believe this to be because of the lights connected to the ikea gateway is not recognized as lights as device type by the ikea tradfri gateway app in homey.

Have I missed something or is it possible to specify device type to my lights in the ikea tradfri gateway app?

Does someone else also have this problem a few times a day? I have to restart the app to make it work again.

Hi Robert or others that can help with maybe a very stupid mistake ?
i can switch on/off from the ikea app and from the remote but homey doesn’t recognize the E14 bulb!

after following the steps mentioned by Robert above, the homey doesn’t discover my E14 bulb
everything works from the ikea devices (so gateway, remote control and the E14 bulb)
The homey installed with the app but doesn’t the homey setup with some security code?
I hope someone knows why and what steps should be done?

Oef two apps
tradfri and tradfri gateway (i installed the first one)
That’s the problem i guess ?
why should you use tradfri without gateway?

Pull the plug on your Tradfri hub and then restart the app

I’ve tried this a minute ago. See if it will work… thanks