How to use "GET JSONPath" as a condition in a flow

I´m trying to create a flow that triggers on a certain time(09:00). In addition to this I also want to read an external value from a API to use as a condtion in the flow, and I think the GET JSONpath is the right card to be used…but there it stops. My scene looks like this:

What do I put into the tree fields? I´d like the parameter “Value” in the JSON-structure I read to equal “Kveld”.

and the JSON structure I can read looks like this:

I´ve been trying to read about the JSON expression but do not fully understand the idea…

@Erik Hi Mr Erik
How would you explain how to do this to a non-programmer? I am however good at using exampled and modify things that others have made😀


  1. field there should be url like you have made.
  2. field can be left empty, in this you can make full json query if needed for example headers etc.
  3. field insert $.value and you get the value of “value” which is “Kveld” in this case
  4. field insert condition. I think it works that if you want to make the condition “true” when the “value” is “Kveld” you insert Kveld in the condition field. Don’t know if the parenthes are required or not.

Thank you very much! Your suggestion is one of many things I have tried, but the app seems to crash.
Now I know the correct “syntax” of the three fields, but perhaps it is the embedded credentials in the url makes the app fail?

That could be an issue, the URL now has two @'s which isn’t allowed. Replace the first (in the username part) with %40 (so…)

Seems like there something with the URL and the embedded user/password. I could also see that a timeout message appeared a short time. Perhaps the user/pssword should be in the header? (first field below URL-field)

I thing it has to be something with the app itself (or the way I use it). I have now changed to another url without need for credentials and the same happens, it crashes:

I have tried with and without “” in the last field…

One step forward. I need to put in {} in the first field after the URL

SOLVED: I had to explicitly type in {} in the first field after the URL-field.