How to link Ikea Dimmer Switch with a Zigbee Bulb

Just a quick addition to this more generic article (and note to self):

Tested with Tradfri and Osram Smart+ bulbs:

  1. Unscrew the switch back
  2. Pair the switch with Homey as usual (4x quick press on pairing button)
  3. Keep the switch really close to the bulb and keep the pairing button pressed for 10s until the bulb also starts to pulse, keep pressed until it turns fully on.

These are great little switches with the magnetic mount and dim function. It means the kids can control their light themselves without the hassle of getting more zigbee buttons setting up a bunch of flows (On/Off/Dim). :slight_smile:


Small Update: I think there is an issue with the 5.0 RC FW.

  • I added one Ikea Wireless Switch to the first bulb as described above: works fine!
  • But after I added a second Bulb + Switch, things started to get weird: as soon as I paired the second switch with the second bulb, I ended up both switches controlling both bulbs in the same way (so bulbs behaved as a group and the Switches as well)!

I only paired one RC to one of the bulbs, and had removed all devices from Homey + reset them.
Removing one switch from Homey fixes it for the second bulb, so there seems to be a switch-bulb link somehwere. Although from what I understood no Homey should theoretically be involved in this type of connection, it still might be related to the new Zigbee stack somehow?

Can anyone try this with 4.2 to see if it works there?

[Update] Even when removing the second switch, the first bulb still turns on/off by itself somehow. Only removing all switches from Homey fixes it.

I don’t think it’s even possible with v4 to bind remotes to bulbs, but you’re not the only one for which it happens.

Thanks, good find! I opened a support request, so let’s see if it can be fixed.
Would be nice to be able to use these switches!


I am experiencing the same behavior when connecting multiple switches to different groups of bulbs. Did you get a reply from Athom on your support request? Looks like the support page you linked to has been taken down…

Not really, they tried several times just to close the ticket. But eventually they stated that they would try to repro the setup, as suggested by me. Not really convinced about that though. :frowning:

I hope they will, but please open a case with them anyway!

OK. -Thanks for sharing, ticket created :slight_smile:

Got a reply - looking forward to the update coming to the IKEA-app :+1:

Hi Thomas,

Thank you for reporting this issue, and our apologies for your inconvenience!

This issue is already reported by other users and Development is working hard to fix this issue.

We hope to resolve this problem with the next update of Ikea app.

1 Like

I have 3 sets of Tradfri drivers (transformers) paired to homey and also separately controllable by 3 Tradfri rotating dimmers. I originally paired all of these to Homey on v4.0 firmware, but now on v5.0 experimental firmware everything still works OK. My steps were as follows:

  1. Connect rotating dimmer to Homey per app instruction (this includes pressing the pairing button 4 times in 5 seconds, which will reset the dimmer and unlink previously paired lights – if any)
  2. Disconnect power from all transformers, except the one you are going to pair first
  3. Connect the transformer to Homey first, during pairing press the reset button (recessed button on transformer case) rather than toggle it on/off per app instructions
  4. Check the transformer is successfully connected to Homey by turning it off and back on etc. from Homey app. Leave the transformer on.
  5. Pair the transformer with rotating dimmer by pressing rotating dimmer pairing button for 10 seconds or more. You will see the lights connected to transformer blink / dim and the LED indicator on rotating dimmer will turn on, “breathe” during the pairing process and turn off when the process is finished. Keep the pairing button pressed until the LED indicator goes off.
  6. Check the transformer is successfully paired with both Homey and rotating dimmer.
  7. Disconnect power from the first paired transformer, connect the next transformer power and repeat steps 3-7.
  8. After all transformers are paired with both Homey and rotating dimmer connect all transformers to power. If you find that some of the transformers do not respond to rotating dimmer anymore bring the dimmer closer to such transformers and short-press the pairing button, red LED indicator on rotating dimmer will turn on, “breathe” for a couple of seconds and turn off.

For the sake of full disclosure – I’m not 100% sure on the very last step as short press of the pairing button is not documented in IKEA manual and I’m not sure what it actually does. In my case, after power up all transformers on the last step I found that only the last connected transformer works with rotating dimmer (all of them responded to Homey though). I believe that bringing the rotating dimmer closer to non-working transformers and short-pressing the pairing button restores the link (in my case I tried re-pairing them a bunch of times, but short-press did the trick finally for me, I think).
Note that this way will also get your rotating dimmer connected to Homey. I didn’t need this and tried to skip step 1 first, but it seems essential. If dimmer is not connected to Homey first, connecting it to the transformer breaks the link between the Homey and the transformer.

I didn’t try this with non-Tradfri zigbee lights though.


Seems the support article mentioned in the OP was removed?
Also on FW5 RC56 it does not seem to work (any more?) with Aqara tunableE27 bulbs.

I’ve come across the same issue (Binding issues (dutch)), however, my response from support was that they’re too busy to fix this. Have you heard anything from them since then?